aboutsummarylogtreecommitdiffstats
path: root/config.mk
diff options
context:
space:
mode:
authorHiltjo Posthuma2015-10-20 23:01:49 +0200
committerHiltjo Posthuma2015-10-20 23:01:49 +0200
commit713f871bd5fd16f60483e7c2a1228a47ad8b91ef (patch)
tree1a9737383ae25797e3d36aedd686f3278fd3609c /config.mk
parenta8140d03d89bc474d9f24bff9db7ba7fc5987197 (diff)
downloadaur-713f871bd5fd16f60483e7c2a1228a47ad8b91ef.tar.gz
config.mk: add $FREETYPELIBS and $FREETYPEINC, simpler to override (ports and *BSDs)
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/config.mk b/config.mk
index cf959131ef7a..4eefb7185faf 100644
--- a/config.mk
+++ b/config.mk
@@ -14,9 +14,15 @@ X11LIB = /usr/X11R6/lib
XINERAMALIBS = -lXinerama
XINERAMAFLAGS = -DXINERAMA
+# freetype
+FREETYPELIBS = -lfontconfig -lXft
+FREETYPEINC = /usr/include/freetype2
+# OpenBSD (uncomment)
+#FREETYPEINC = ${X11INC}/freetype2
+
# includes and libs
-INCS = -I${X11INC} -I/usr/include/freetype2
-LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS} -lfontconfig -lXft
+INCS = -I${X11INC} -I${FREETYPEINC}
+LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS} ${FREETYPELIBS}
# flags
CPPFLAGS = -D_BSD_SOURCE -D_POSIX_C_SOURCE=2 -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}