aboutsummarylogtreecommitdiffstats
path: root/config.mk
diff options
context:
space:
mode:
authorAnselm R Garbe2009-06-20 15:10:04 +0100
committerAnselm R Garbe2009-06-20 15:10:04 +0100
commitcf9730ead210bb3f488eb55a6e9f50ceb15beb0e (patch)
tree26d04c09af30815f609994d4ed74802a4315f485 /config.mk
parentb677c19c443bc5e35740532a877c752f1fc53a44 (diff)
downloadaur-cf9730ead210bb3f488eb55a6e9f50ceb15beb0e.tar.gz
experimental xinerama support, two new actions, Mod1-w/e and Mod1-Shift-w/e
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/config.mk b/config.mk
index 43c324b55715..f5ec4c17a727 100644
--- a/config.mk
+++ b/config.mk
@@ -11,8 +11,8 @@ X11INC = /usr/X11R6/include
X11LIB = /usr/X11R6/lib
# Xinerama, un-comment if you want it
-#XINERAMALIBS = -L${X11LIB} -lXinerama
-#XINERAMAFLAGS = -DXINERAMA
+XINERAMALIBS = -L${X11LIB} -lXinerama
+XINERAMAFLAGS = -DXINERAMA
# includes and libs
INCS = -I. -I/usr/include -I${X11INC}
@@ -20,8 +20,10 @@ LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
# flags
CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-LDFLAGS = -s ${LIBS}
+CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+#CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+LDFLAGS = -g ${LIBS}
+#LDFLAGS = -s ${LIBS}
# Solaris
#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"