summarylogtreecommitdiffstats
path: root/configure.patch
diff options
context:
space:
mode:
authorkfg2018-02-06 12:13:02 +0100
committerkfg2018-02-06 12:23:52 +0100
commit3b03b7d4888202f3ece504792eb7a455891e2220 (patch)
tree90c9c4e983acd779b118616dbd4c2fb83f3a18af /configure.patch
parent5eb12b8ab87c7a294a24c6a1607909f05dc546dd (diff)
downloadaur-3b03b7d4888202f3ece504792eb7a455891e2220.tar.gz
upgpkg: mingw-w64-libvpx 1.7.0-1
new upstream release
Diffstat (limited to 'configure.patch')
-rw-r--r--configure.patch44
1 files changed, 22 insertions, 22 deletions
diff --git a/configure.patch b/configure.patch
index 560ad66a1591..38f5f8eaa13d 100644
--- a/configure.patch
+++ b/configure.patch
@@ -1,7 +1,7 @@
-diff -ru libvpx-1.6.1/build/make/configure.sh patched/build/make/configure.sh
---- libvpx-1.6.1/build/make/configure.sh 2017-01-12 21:27:27.000000000 +0100
-+++ patched/build/make/configure.sh 2017-04-14 12:02:03.691725079 +0200
-@@ -1279,11 +1279,13 @@
+diff -ru libvpx-1.7.0/build/make/configure.sh patched/build/make/configure.sh
+--- libvpx-1.7.0/build/make/configure.sh 2018-01-24 23:25:44.000000000 +0100
++++ patched/build/make/configure.sh 2018-02-06 12:17:03.422724302 +0100
+@@ -1346,11 +1346,13 @@
win32)
add_asflags -f win32
enabled debug && add_asflags -g cv8
@@ -9,16 +9,16 @@ diff -ru libvpx-1.6.1/build/make/configure.sh patched/build/make/configure.sh
EXE_SFX=.exe
;;
win64)
- add_asflags -f x64
+ add_asflags -f win64
enabled debug && add_asflags -g cv8
+ add_ldflags "-Wl,-no-undefined"
EXE_SFX=.exe
;;
linux*|solaris*|android*)
-diff -ru libvpx-1.6.1/build/make/Makefile patched/build/make/Makefile
---- libvpx-1.6.1/build/make/Makefile 2017-01-12 21:27:27.000000000 +0100
-+++ patched/build/make/Makefile 2017-04-14 12:02:03.691725079 +0200
-@@ -296,6 +296,7 @@
+diff -ru libvpx-1.7.0/build/make/Makefile patched/build/make/Makefile
+--- libvpx-1.7.0/build/make/Makefile 2018-01-24 23:25:44.000000000 +0100
++++ patched/build/make/Makefile 2018-02-06 12:15:22.321327551 +0100
+@@ -303,6 +303,7 @@
$(if $(quiet),@echo " [LD] $$@")
$(qexec)$$(LD) -shared $$(LDFLAGS) \
-Wl,--no-undefined -Wl,-soname,$$(SONAME) \
@@ -26,7 +26,7 @@ diff -ru libvpx-1.6.1/build/make/Makefile patched/build/make/Makefile
-Wl,--version-script,$$(EXPORTS_FILE) -o $$@ \
$$(filter %.o,$$^) $$(extralibs)
endef
-@@ -380,7 +381,7 @@
+@@ -387,7 +388,7 @@
.libs: $(LIBS)
@touch $@
$(foreach lib,$(filter %_g.a,$(LIBS)),$(eval $(call archive_template,$(lib))))
@@ -35,10 +35,10 @@ diff -ru libvpx-1.6.1/build/make/Makefile patched/build/make/Makefile
$(foreach lib,$(filter %$(SO_VERSION_MAJOR).dylib,$(LIBS)),$(eval $(call dl_template,$(lib))))
$(foreach lib,$(filter %$(SO_VERSION_MAJOR).dll,$(LIBS)),$(eval $(call dll_template,$(lib))))
-diff -ru libvpx-1.6.1/configure patched/configure
---- libvpx-1.6.1/configure 2017-01-12 21:27:27.000000000 +0100
-+++ patched/configure 2017-04-14 12:02:03.691725079 +0200
-@@ -491,23 +491,23 @@
+diff -ru libvpx-1.7.0/configure patched/configure
+--- libvpx-1.7.0/configure 2018-01-24 23:25:44.000000000 +0100
++++ patched/configure 2018-02-06 12:15:22.321327551 +0100
+@@ -513,23 +513,23 @@
}
process_detect() {
@@ -75,9 +75,9 @@ diff -ru libvpx-1.6.1/configure patched/configure
if [ -z "$CC" ] || enabled external_build; then
echo "Bypassing toolchain for environment detection."
enable_feature external_build
-diff -ru libvpx-1.6.1/examples.mk patched/examples.mk
---- libvpx-1.6.1/examples.mk 2017-01-12 21:27:27.000000000 +0100
-+++ patched/examples.mk 2017-04-14 12:07:14.397325649 +0200
+diff -ru libvpx-1.7.0/examples.mk patched/examples.mk
+--- libvpx-1.7.0/examples.mk 2018-01-24 23:25:44.000000000 +0100
++++ patched/examples.mk 2018-02-06 12:15:22.321327551 +0100
@@ -314,7 +314,7 @@
ifneq ($(filter os2%,$(TGT_OS)),)
SHARED_LIB_SUF=_dll.a
@@ -87,10 +87,10 @@ diff -ru libvpx-1.6.1/examples.mk patched/examples.mk
endif
endif
CODEC_LIB_SUF=$(if $(CONFIG_SHARED),$(SHARED_LIB_SUF),.a)
-diff -ru libvpx-1.6.1/libs.mk patched/libs.mk
---- libvpx-1.6.1/libs.mk 2017-01-12 21:27:27.000000000 +0100
-+++ patched/libs.mk 2017-04-14 12:02:03.701725259 +0200
-@@ -255,12 +255,12 @@
+diff -ru libvpx-1.7.0/libs.mk patched/libs.mk
+--- libvpx-1.7.0/libs.mk 2018-01-24 23:25:44.000000000 +0100
++++ patched/libs.mk 2018-02-06 12:15:22.321327551 +0100
+@@ -256,12 +256,12 @@
LIBVPX_SO_SYMLINKS :=
LIBVPX_SO_IMPLIB := libvpx_dll.a
else
@@ -107,7 +107,7 @@ diff -ru libvpx-1.6.1/libs.mk patched/libs.mk
endif
endif
endif
-@@ -270,7 +270,7 @@
+@@ -271,7 +271,7 @@
$(if $(LIBVPX_SO_IMPLIB), $(BUILD_PFX)$(LIBVPX_SO_IMPLIB))
$(BUILD_PFX)$(LIBVPX_SO): $(LIBVPX_OBJS) $(EXPORT_FILE)
$(BUILD_PFX)$(LIBVPX_SO): extralibs += -lm