summarylogtreecommitdiffstats
path: root/consul-template@.service
diff options
context:
space:
mode:
authorBazaah2021-04-25 14:35:18 +0000
committerBazaah2021-04-25 15:02:00 +0000
commitc95cdb9cf1475f1e8006a3b08e8bce2fbb090dda (patch)
tree2895a171d6465d411ed23b83dacdc96c0f498c29 /consul-template@.service
downloadaur-c95cdb9cf1475f1e8006a3b08e8bce2fbb090dda.tar.gz
consul-template-bin: <NIL> -> 0.25.2_1
- add PKGBUILD + SRCINFO - add local sources - add CHANGELOG for 0.25.2 - add .gitignore This commit adds a new PKGBUILD for pulling binary variants for HashiCorp's consul-template.
Diffstat (limited to 'consul-template@.service')
-rw-r--r--consul-template@.service18
1 files changed, 18 insertions, 0 deletions
diff --git a/consul-template@.service b/consul-template@.service
new file mode 100644
index 000000000000..99b0fb4c314c
--- /dev/null
+++ b/consul-template@.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Template (:%i) rendering, notifier, and supervisor for HashiCorp Consul and Vault
+Documentation=https://github.com/hashicorp/consul-template
+PartOf=consul-template.target
+
+[Service]
+
+# You want to run Consul-template as a non root user, particularly when using it in exec mode
+# User=consul
+# Group=consul
+
+EnvironmentFile=-/etc/default/consul-template
+ExecStart=/usr/bin/consul-template -config /etc/consul-template.d/%i.hcl
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillSignal=SIGINT
+
+[Install]
+WantedBy=multi-user.target