summarylogtreecommitdiffstats
path: root/curl-7.71.0.patch
diff options
context:
space:
mode:
authorAaron Bishop2020-06-25 10:10:41 -0400
committerAaron Bishop2020-06-25 10:10:41 -0400
commit261d84887d736cc097abef61164339216fb79180 (patch)
tree430a98871f7a7aab4ed46147c0f7e88999da0ab2 /curl-7.71.0.patch
parent752b716d13c0e4137851f4e5cde761d7749b970c (diff)
downloadaur-261d84887d736cc097abef61164339216fb79180.tar.gz
Update to be compatible with curl-7.71.0
Diffstat (limited to 'curl-7.71.0.patch')
-rw-r--r--curl-7.71.0.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/curl-7.71.0.patch b/curl-7.71.0.patch
new file mode 100644
index 000000000000..7ab21ef659ee
--- /dev/null
+++ b/curl-7.71.0.patch
@@ -0,0 +1,24 @@
+--- a/Curl.xs 2014-02-21 11:08:30.000000000 -0500
++++ b/Curl.xs 2020-06-25 09:36:37.868826340 -0400
+@@ -18,6 +18,10 @@
+ #include <curl/easy.h>
+ #include <curl/multi.h>
+
++#if defined(CURLINC_MULTI_H) && !defined(__CURL_MULTI_H)
++# define __CURL_MULTI_H
++#endif
++
+ #define header_callback_func writeheader_callback_func
+
+ /* Do a favor for older perl versions */
+--- a/Makefile.PL 2014-02-21 11:08:09.000000000 -0500
++++ b/Makefile.PL 2020-06-25 09:24:50.549812170 -0400
+@@ -127,7 +127,7 @@
+ close H;
+
+ for my $e (sort @syms) {
+- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
++ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_WIN32\z|^CURLOPT\z|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z)/) {
+ next;
+ }
+ my ($group) = $e =~ m/^([^_]+_)/;