summarylogtreecommitdiffstats
path: root/dep.patch
diff options
context:
space:
mode:
authorpingplug2017-08-07 10:59:26 +0800
committerpingplug2017-08-07 10:59:26 +0800
commit7925bcae87b1885ad62ee1f0c757a6ef54e096b3 (patch)
tree681a883cc3d546983cf7441ab0107670d9776078 /dep.patch
parent173f1b337cbb07123434308f6d1443eb5b0a83b5 (diff)
downloadaur-7925bcae87b1885ad62ee1f0c757a6ef54e096b3.tar.gz
Fix openexr detection
Diffstat (limited to 'dep.patch')
-rw-r--r--dep.patch29
1 files changed, 26 insertions, 3 deletions
diff --git a/dep.patch b/dep.patch
index 857d309e9f07..eaafbb52313d 100644
--- a/dep.patch
+++ b/dep.patch
@@ -1,7 +1,30 @@
diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1/configure.ac
---- cinelerra-gg/cinelerra-5.1/configure.ac 2017-02-11 12:05:00.232197909 +0800
-+++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2017-02-11 12:01:24.000000000 +0800
-@@ -603,7 +603,7 @@
+--- cinelerra-gg/cinelerra-5.1/configure.ac 2017-08-07 10:39:25.977492228 +0800
++++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2017-08-07 10:37:58.000000000 +0800
+@@ -547,8 +547,8 @@
+ EXRIStream() : Imf::IStream("mypath") {} };
+ class EXROStream : public Imf::OStream { public:
+ EXROStream() : Imf::OStream("mypath") {} };
+-]])], [HAVE_OPENEXR=yes], [HAVE_OPENEXR=no])
+- RESULT="$HAVE_OPENEXR"
++]])], [HAVE_openexr=yes], [HAVE_openexr=no])
++ RESULT="$HAVE_openexr"
+ if test "x$RESULT" = "xyes"; then
+ SHARED_openexr="$LIBS"
+ CFG_CFLAGS+=" -I/usr/include/OpenEXR"
+@@ -556,9 +556,9 @@
+ LIBS="$saved_LIBS"
+ CXXFLAGS="$saved_CXXFLAGS"
+ AC_LANG_POP(C++)
+- AC_MSG_RESULT([$HAVE_OPENEXR])
++ AC_MSG_RESULT([$HAVE_openexr])
+ ])
+-AC_SUBST([HAVE_OPENEXR])
++AC_SUBST([HAVE_openexr])
+
+ # build global_config
+ OBJDIR=`uname -m`
+@@ -597,7 +597,7 @@
libtheora/libogg libtheora/libvorbis ; do
lib=`dirname $dep`; needs=`basename $dep`
eval pkg_lib="\$PKG_$lib"; eval needs_lib="\$HAVE_$needs";