summarylogtreecommitdiffstats
path: root/depot_tools.install
diff options
context:
space:
mode:
authorrelrel2020-09-25 14:03:37 +0300
committerrelrel2020-09-25 14:03:37 +0300
commitf9b79b0c2e94a452a88856db2f3c4b940ecfe952 (patch)
treebe5369ce3b8271be00c87e02e882febdf031d193 /depot_tools.install
parentf57457d60eabbfdc4072ac5001a1889461fe2477 (diff)
downloadaur-f9b79b0c2e94a452a88856db2f3c4b940ecfe952.tar.gz
Major refactoring
The key guideline that I followed here is to avoid patches as much as possible, in order to keep this package simple and clean. So I deciced to not depend on ninja and python2, and instead just use those that come with depot_tools. Also, I think that most of the python2 issues have been resolved upstream by now, and there is no need to force scripts to run using python2 anymore. Finally, I did many small cleanups in PKGBUILD, and added bash completion for gclient and git cl.
Diffstat (limited to 'depot_tools.install')
-rw-r--r--depot_tools.install22
1 files changed, 0 insertions, 22 deletions
diff --git a/depot_tools.install b/depot_tools.install
deleted file mode 100644
index c7ab750ed0ce..000000000000
--- a/depot_tools.install
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/bash
-
-_prompt_modify_path()
-{
- cat << EOF
->>>> Add export PATH="\${PATH}:/opt/depot_tools" to .bashrc/.zshrc or setenv PATH "\${PATH}:/opt/depot_tools" to ~/.tcshrc if you don't find any depot_tools related commands."
-EOF
-}
-
-post_install()
-{
- echo ">>>> Please note that this tools and some related projects (for example ChromeOS) use python2."
- echo ">>>> They assume that python2 is the default python interpreter. ArchLinux default is python3, so be prepared to fix python references in your works."
- echo ">>>> This package contains a repo_fix.sh script. Use it to fix python2 references in python's script created after 'repo init' command"
- echo ">>>> For getting started with depot_tools, visit this page: https://dev.chromium.org/developers/how-tos/depottools"
- _prompt_modify_path
-}
-
-post_upgrade()
-{
- _prompt_modify_path
-}