summarylogtreecommitdiffstats
path: root/dgrp-install.sh
diff options
context:
space:
mode:
authorChris Severance2015-08-07 12:28:35 -0400
committerChris Severance2015-08-07 12:28:35 -0400
commitf2abf45a1ee0380ae5a28517bc2539b2f0d64bfb (patch)
tree01cfbc94e0fe875f5083d526ccbe9a5b222e5673 /dgrp-install.sh
parent46aff6896e80489c9e6e414f9a572d4509ff8a12 (diff)
downloadaur-f2abf45a1ee0380ae5a28517bc2539b2f0d64bfb.tar.gz
PKGBUILD improvements
Diffstat (limited to 'dgrp-install.sh')
-rw-r--r--dgrp-install.sh19
1 files changed, 12 insertions, 7 deletions
diff --git a/dgrp-install.sh b/dgrp-install.sh
index 7b2fa441f5c2..4334cfc15fe3 100644
--- a/dgrp-install.sh
+++ b/dgrp-install.sh
@@ -4,15 +4,16 @@
post_upgrade() {
set -u
mandb -q
- /usr/bin/dgrp/config/postinstall # this runs depmod -a
- rmdir '/tmp/dgrp' # postinstall forgets to remove this. Useful on /tmp folders that are not mounted tmpfs
+ /usr/bin/dgrp/config/postinstall # this used to run depmod -a
+ depmod -a
+ # rmdir '/tmp/dgrp' # postinstall forgets to remove this. Useful on /tmp folders that are not mounted tmpfs
systemctl daemon-reload
# Digi's postinstall automatically loads the daemons so we might as well too
for _daemon in daemon ditty; do
systemctl enable "dgrp_${_daemon}.service"
systemctl start "dgrp_${_daemon}.service"
done
- echo "RealPort (dgrp) startup scripts updated or installed"
+ #echo "RealPort (dgrp) startup scripts updated or installed"
set +u
}
@@ -22,7 +23,7 @@ post_install() {
pre_upgrade() {
set -u
- for _daemon in daemon ditty; do
+ for _daemon in daemon; do
systemctl stop "dgrp_${_daemon}.service"
systemctl disable "dgrp_${_daemon}.service"
done
@@ -34,8 +35,11 @@ pre_remove() {
pre_upgrade
set -u
. '/usr/bin/dgrp/config/file_locations'
- if [ -f "${DGRP_STORE}" ]; then
- echo "To clean fully you may want to remove your config: ${DGRP_STORE}"
+ if [ -f "${DGRP_STORE}.old" ]; then
+ echo "To clean fully you may want to remove your config backup: ${DGRP_STORE}.old"
+ fi
+ if [ -f "${DGRP_STORE}.pacsave" ]; then
+ echo "To clean fully you may want to remove your config backup: ${DGRP_STORE}.pacsave"
fi
set +u
}
@@ -44,6 +48,7 @@ post_remove() {
set -u
mandb -q
systemctl daemon-reload
- echo "RealPort (dgrp) startup scripts removed"
+ #echo "RealPort (dgrp) startup scripts removed"
set +u
}
+# Automatically generated by dgrp-1.9.35 PKGBUILD from Arch Linux AUR