summarylogtreecommitdiffstats
path: root/dingo.config
diff options
context:
space:
mode:
authorNikolay Arhipov2017-05-20 00:21:02 +0300
committerNikolay Arhipov2017-05-20 00:21:02 +0300
commite67b32ddbbdf80e7ae307b006a6bfb9bf2b770b8 (patch)
tree6f5a7fbebf2a1c458e20f155778c58dc56d089b5 /dingo.config
downloadaur-e67b32ddbbdf80e7ae307b006a6bfb9bf2b770b8.tar.gz
Initial PKGBUILD
Diffstat (limited to 'dingo.config')
-rw-r--r--dingo.config35
1 files changed, 35 insertions, 0 deletions
diff --git a/dingo.config b/dingo.config
new file mode 100644
index 000000000000..b7040fb6f915
--- /dev/null
+++ b/dingo.config
@@ -0,0 +1,35 @@
+# Usage of dingo-linux-amd64:
+# -bind string
+# IP address to bind to (default "127.0.0.1")
+# -dbg int
+# debugging level (default 2)
+# -gdns:auto
+# Google DNS: try to lookup the closest IPv4 server
+# -gdns:edns string
+# Google DNS: EDNS client subnet (set 0.0.0.0/0 to disable)
+# -gdns:host string
+# Google DNS: HTTP 'Host' header (real FQDN, encrypted in TLS) (default "dns.google.com")
+# -gdns:nopad
+# Google DNS: disable random padding
+# -gdns:server string
+# Google DNS: server address (default "216.58.195.78")
+# -gdns:sni string
+# Google DNS: SNI string to send (should match server certificate) (default "www.google.com")
+# -gdns:workers int
+# Google DNS: number of independent workers (default 10)
+# -h1
+# use HTTPS/1.1 transport
+# -odns:host string
+# OpenDNS: HTTP 'Host' header (real FQDN, encrypted in TLS) (default "api.openresolve.com")
+# -odns:server string
+# OpenDNS: web server address (default "67.215.70.81")
+# -odns:sni string
+# OpenDNS: TLS SNI string to send (unencrypted, must validate as server cert) (default "www.openresolve.com")
+# -odns:workers int
+# OpenDNS: number of independent workers
+# -port int
+# listen on port number (default 32000)
+ARGS=\
+ -port=53 \
+ -gdns:auto
+