summarylogtreecommitdiffstats
path: root/discord_arch_electron.install
diff options
context:
space:
mode:
authorManuel Hüsers2024-06-09 21:58:06 +0200
committerManuel Hüsers2024-06-09 21:58:06 +0200
commit9fafba484a420eb6acbc4fa7d92220a621f6e96e (patch)
tree06d91b459d3d7f61cefe0e0b29679e1f6c59cc70 /discord_arch_electron.install
parent3cb800694bd6a6c56bb3c399a43193a448dcee83 (diff)
downloadaur-9fafba484a420eb6acbc4fa7d92220a621f6e96e.tar.gz
upgpkg: discord 0.0.55-2: refactor, fix autostart, add deps, use wayland
* Slightly refactor PKGBUILD * Fix autostart desktop file * Add optional dependency used in official arch package * Include patcher to allow Krisp noise suppression support * Add install file to inform user about this change * Use Wayland instead of Xwayland in a Wayland session by setting Electron flag `ozone-platform-hint` to auto (default is X11)
Diffstat (limited to 'discord_arch_electron.install')
-rw-r--r--discord_arch_electron.install19
1 files changed, 19 insertions, 0 deletions
diff --git a/discord_arch_electron.install b/discord_arch_electron.install
new file mode 100644
index 000000000000..f400a05931e3
--- /dev/null
+++ b/discord_arch_electron.install
@@ -0,0 +1,19 @@
+post_upgrade() {
+ # return if old package version is greater than or equal to 0.0.55-2...
+ (( $(vercmp $2 '0.0.55-2') >= 0 )) && return
+
+ cat <<EOF
+==> In order to patch Krisp noise suppression support set 'PATCH_KRISP=true'
+ in '~/.config/discord.conf' and install the necessary optional dependencies.
+EOF
+}
+
+post_install() {
+ cat <<EOF
+==> For Krisp noise suppression support consider installing the necessary optional
+ dependencies and setting 'PATCH_KRISP=true' in '~/.config/discord.conf'.
+ Restart your Discord client afterwards to apply the patch.
+==> In case of performance problems consider setting additional flags
+ in '~/.config/discord-flags.conf'.
+EOF
+}