summarylogtreecommitdiffstats
path: root/electricsheep-no-wxgtk.patch
diff options
context:
space:
mode:
authorDavid Runge2017-12-26 21:59:18 +0100
committerDavid Runge2017-12-26 21:59:18 +0100
commit5f1e7155b5c668b99898e4bd09b81b33af9a30c9 (patch)
tree1c65c119dc27d511d5ca520e40597757d5e339c5 /electricsheep-no-wxgtk.patch
downloadaur-5f1e7155b5c668b99898e4bd09b81b33af9a30c9.tar.gz
Moved from [community] due to unmaintained upstream and dependency on glee.
Diffstat (limited to 'electricsheep-no-wxgtk.patch')
-rw-r--r--electricsheep-no-wxgtk.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/electricsheep-no-wxgtk.patch b/electricsheep-no-wxgtk.patch
new file mode 100644
index 000000000000..dd1a6026dc16
--- /dev/null
+++ b/electricsheep-no-wxgtk.patch
@@ -0,0 +1,77 @@
+--- configure.ac.orig 2014-08-17 17:28:46.314141026 -0400
++++ configure.ac 2014-08-17 17:29:21.084084594 -0400
+@@ -71,64 +71,7 @@
+
+
+
+-dnl Check for WXWidgets
+-WX_VER_291=""
+
+-AC_PATH_PROG(WX_CONFIG, wx-config, no)
+-
+-if test x$WX_CONFIG != xno; then
+- WX_VERSION=`wx-config --version`
+-
+- WX_MAJOR=${WX_VERSION%%.*};
+- WX_MINOR=${WX_VERSION#*.};
+- WX_MINOR=${WX_MINOR%%.*};
+- WX_MICRO=${WX_VERSION##*.};
+-
+- if test $WX_MAJOR -gt 2; then
+- WX_VER_291=yes
+- else
+- if test $WX_MAJOR -eq 2; then
+- if test $WX_MINOR -gt 9; then
+- WX_VER_291=yes
+- else
+- if test $WX_MINOR -eq 9; then
+- if test $WX_MICRO -ge 1; then
+- WX_VER_291=yes
+- fi
+- fi
+- fi
+- fi
+- fi
+-fi
+-
+-if test "$WX_VER_291" != "yes"; then
+-
+-dnl Use static version
+-echo "installed version is too old,"
+-echo "using static source version $reqwx"
+-
+-dnl Need to reset this, else it will override the value below !
+-WX_CONFIG=""
+-
+-AC_CHECK_PROG(WX_CONFIG, wx-config, yes, no)
+-
+-if test $WX_CONFIG = no; then
+-echo
+-echo YOU CAN FIX THIS !
+-AC_MSG_ERROR([Please install development libraries for wxWidgets 2.9.1 or higher, and then run this configure script again.])
+-fi
+-fi
+-
+-WX_CXXFLAGS="`wx-config --cxxflags`"
+-WX_LIBS="-static `wx-config --libs` `wx-config --libs richtext`"
+-
+-echo "WX_CXXFLAGS is $WX_CXXFLAGS"
+-echo "WX_LIBS is $WX_LIBS"
+-
+-WX_LDADD="$WX_LIBS"
+-
+-AC_SUBST(WX_CXXFLAGS)
+-AC_SUBST(WX_LDADD)
+
+
+
+--- MSVC/SettingsGUI/Makefile.am.orig 2014-08-17 20:22:59.680508699 -0400
++++ MSVC/SettingsGUI/Makefile.am 2014-08-17 20:23:46.397099541 -0400
+@@ -28,7 +28,6 @@
+ -I /usr/include/libswscale \
+ -I /usr/include/libavutil
+
+-bin_PROGRAMS = electricsheep-preferences
+
+ electricsheep_preferences_SOURCES = \
+ config.cpp \