summarylogtreecommitdiffstats
path: root/electron-cash-git.install
diff options
context:
space:
mode:
authorDan Beste2017-08-18 10:56:49 -0500
committerDan Beste2017-08-18 10:56:49 -0500
commitae5ee0fcff9f936d1bc074f71282c8a4d6a34656 (patch)
tree8c8205f0aead4d5150e2b499cf0b9b91855ebd0d /electron-cash-git.install
parented894f84bba1649ffb1dba1b7d706434083f1313 (diff)
downloadaur-ae5ee0fcff9f936d1bc074f71282c8a4d6a34656.tar.gz
PKGBUILD cleanup
Diffstat (limited to 'electron-cash-git.install')
-rw-r--r--electron-cash-git.install23
1 files changed, 23 insertions, 0 deletions
diff --git a/electron-cash-git.install b/electron-cash-git.install
new file mode 100644
index 000000000000..c14de3d340f8
--- /dev/null
+++ b/electron-cash-git.install
@@ -0,0 +1,23 @@
+post_install() {
+ if [[ -x /usr/bin/update-desktop-database ]]; then
+ update-desktop-database -q
+ fi
+
+ if [[ -x /usr/bin/xdg-icon-resource ]]; then
+ xdg-icon-resource forceupdate --theme hicolor
+ fi
+
+ if [[ -x /usr/bin/gtk-update-icon-cache ]]; then
+ gtk-update-icon-cache -f -q /usr/share/icons/hicolor
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: