summarylogtreecommitdiffstats
path: root/enchant-2.patch
diff options
context:
space:
mode:
authorEugene Lamskoy2021-12-03 20:39:36 +0200
committerEugene Lamskoy2021-12-03 20:39:36 +0200
commit8a8eda42e6c14a0ce484b6a60db87e1643673f68 (patch)
tree31d02a261321ea490de3d547607154bd9bcf9066 /enchant-2.patch
parent249f1ee0d8c0dbd87217f8375545486ec8994eb8 (diff)
downloadaur-8a8eda42e6c14a0ce484b6a60db87e1643673f68.tar.gz
Cleaned up PKGBUILD
Diffstat (limited to 'enchant-2.patch')
-rw-r--r--enchant-2.patch84
1 files changed, 0 insertions, 84 deletions
diff --git a/enchant-2.patch b/enchant-2.patch
deleted file mode 100644
index 93c0ce5c269e..000000000000
--- a/enchant-2.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- php-7.1.13/ext/enchant/config.m4.orig 2018-01-03 02:32:29.000000000 +0000
-+++ php-7.1.13/ext/enchant/config.m4 2018-01-21 22:10:03.788875780 +0000
-@@ -14,9 +14,9 @@
- ENCHANT_SEARCH_DIRS="/usr/local /usr"
- fi
- for i in $ENCHANT_SEARCH_DIRS; do
-- if test -f $i/include/enchant/enchant.h; then
-+ if test -f $i/include/enchant-2/enchant.h; then
- ENCHANT_DIR=$i
-- ENCHANT_INCDIR=$i/include/enchant
-+ ENCHANT_INCDIR=$i/include/enchant-2
- elif test -f $i/include/enchant.h; then
- ENCHANT_DIR=$i
- ENCHANT_INCDIR=$i/include
-@@ -31,7 +31,7 @@
-
- AC_DEFINE(HAVE_ENCHANT,1,[ ])
- PHP_SUBST(ENCHANT_SHARED_LIBADD)
-- PHP_ADD_LIBRARY_WITH_PATH(enchant, $ENCHANT_LIBDIR, ENCHANT_SHARED_LIBADD)
-+ PHP_ADD_LIBRARY_WITH_PATH(enchant-2, $ENCHANT_LIBDIR, ENCHANT_SHARED_LIBADD)
- PHP_ADD_INCLUDE($ENCHANT_INCDIR)
- PHP_CHECK_LIBRARY(enchant, enchant_broker_set_param,
- [
---- php-7.1.13/configure.orig 2018-01-21 22:03:51.494656374 +0000
-+++ php-7.1.13/configure 2018-01-21 22:12:35.932571143 +0000
-@@ -29838,9 +29838,9 @@
- ENCHANT_SEARCH_DIRS="/usr/local /usr"
- fi
- for i in $ENCHANT_SEARCH_DIRS; do
-- if test -f $i/include/enchant/enchant.h; then
-+ if test -f $i/include/enchant-2/enchant.h; then
- ENCHANT_DIR=$i
-- ENCHANT_INCDIR=$i/include/enchant
-+ ENCHANT_INCDIR=$i/include/enchant-2
- elif test -f $i/include/enchant.h; then
- ENCHANT_DIR=$i
- ENCHANT_INCDIR=$i/include
-@@ -29862,7 +29862,7 @@
-
-
- if test "$ext_shared" = "yes"; then
-- ENCHANT_SHARED_LIBADD="-lenchant $ENCHANT_SHARED_LIBADD"
-+ ENCHANT_SHARED_LIBADD="-lenchant-2 $ENCHANT_SHARED_LIBADD"
- if test -n "$ENCHANT_LIBDIR"; then
-
- if test "$ENCHANT_LIBDIR" != "/usr/$PHP_LIBDIR" && test "$ENCHANT_LIBDIR" != "/usr/lib"; then
---- php-7.2.1/ext/enchant/enchant.c.orig 2018-01-02 22:36:05.000000000 +0000
-+++ php-7.2.1/ext/enchant/enchant.c 2018-01-21 22:34:50.205791491 +0000
-@@ -741,7 +741,7 @@
- for (i = 0; i < n_sugg; i++) {
- add_next_index_string(sugg, suggs[i]);
- }
-- enchant_dict_free_suggestions(pdict->pdict, suggs);
-+ enchant_dict_free_string_list(pdict->pdict, suggs);
- }
-
-
-@@ -798,7 +798,7 @@
- add_next_index_string(return_value, suggs[i]);
- }
-
-- enchant_dict_free_suggestions(pdict->pdict, suggs);
-+ enchant_dict_free_string_list(pdict->pdict, suggs);
- }
- }
- /* }}} */
-@@ -818,7 +818,7 @@
-
- PHP_ENCHANT_GET_DICT;
-
-- enchant_dict_add_to_personal(pdict->pdict, word, wordlen);
-+ enchant_dict_add(pdict->pdict, word, wordlen);
- }
- /* }}} */
-
-@@ -856,7 +856,7 @@
-
- PHP_ENCHANT_GET_DICT;
-
-- RETURN_BOOL(enchant_dict_is_in_session(pdict->pdict, word, wordlen));
-+ RETURN_BOOL(enchant_dict_is_added(pdict->pdict, word, wordlen));
- }
- /* }}} */
-