summarylogtreecommitdiffstats
path: root/entrypoint-name.patch
diff options
context:
space:
mode:
authorMatthew Ellison2016-01-26 11:07:25 -0500
committerMatthew Ellison2016-01-26 11:07:25 -0500
commit9a0e651e9af12a1c757f1e12c8db8e03aa4c97ac (patch)
tree8866e9d81f6a79b2c032df9170fa66d95f56c0d4 /entrypoint-name.patch
parent019e8c24510a794ea8e085538f4e44755313c87b (diff)
downloadaur-9a0e651e9af12a1c757f1e12c8db8e03aa4c97ac.tar.gz
Entrypoint Name Patch
Prevent conflicts with `nsenter` from `core/util-linux`. Entrypoint is now named `nsenter-py`.
Diffstat (limited to 'entrypoint-name.patch')
-rw-r--r--entrypoint-name.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/entrypoint-name.patch b/entrypoint-name.patch
new file mode 100644
index 000000000000..bccb812f276a
--- /dev/null
+++ b/entrypoint-name.patch
@@ -0,0 +1,11 @@
+--- ./setup.py.old 2016-01-26 10:57:42.891058510 -0500
++++ ./setup.py 2016-01-26 10:58:03.320708183 -0500
+@@ -42,7 +42,7 @@
+ setup_requires=['flake8'],
+ install_requires=get_install_requirements('requirements.txt'),
+ packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
+- entry_points={'console_scripts': ['nsenter = nsenter:main']}
++ entry_points={'console_scripts': ['nsenter-py = nsenter:main']}
+ )
+
+ if __name__ == '__main__':