summarylogtreecommitdiffstats
path: root/epherome.sh
diff options
context:
space:
mode:
authorzxp198210052023-07-13 09:21:07 +0800
committerzxp198210052023-07-13 09:21:07 +0800
commitc6ad8d5ce0dba50df9948c9fdbae50e6fe8481d5 (patch)
tree4da54b0588c8b94f901ac5616ebce884c95d25f9 /epherome.sh
parent901f5333bb019cdbaf2404eb00169d5201537cbf (diff)
downloadaur-c6ad8d5ce0dba50df9948c9fdbae50e6fe8481d5.tar.gz
optimized PKGBUILD
Diffstat (limited to 'epherome.sh')
-rw-r--r--epherome.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/epherome.sh b/epherome.sh
new file mode 100644
index 000000000000..a2fedfd41500
--- /dev/null
+++ b/epherome.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron22 /opt/epherome/epherome.asar "$@"
+else
+ exec electron22 --no-sandbox /opt/epherome/epherome.asar "$@"
+fi \ No newline at end of file