summarylogtreecommitdiffstats
path: root/ethoscope-node.install
diff options
context:
space:
mode:
authorGiorgio Gilestro2024-12-08 15:33:04 +0000
committerGiorgio Gilestro2024-12-08 15:33:04 +0000
commit5310445790121091f7a7908bee00ef2c7a831516 (patch)
treee7cfb98f5d0ee07bba720b275108871d5a08d548 /ethoscope-node.install
parentf297287d1d594f775af78bf52e2b3c31bc99c34d (diff)
downloadaur-5310445790121091f7a7908bee00ef2c7a831516.tar.gz
Create the egg for the ethoscope module too
Diffstat (limited to 'ethoscope-node.install')
-rw-r--r--ethoscope-node.install18
1 files changed, 10 insertions, 8 deletions
diff --git a/ethoscope-node.install b/ethoscope-node.install
index 34b3301c03b7..6321c043ed8f 100644
--- a/ethoscope-node.install
+++ b/ethoscope-node.install
@@ -5,16 +5,18 @@
# arg 1: the new package version
post_install() {
+
+ #setting the bare installation folder as safe.directory
+ git config --system --add safe.directory /srv/git/ethoscope.git
+
#echo "changing the remote GIT source to local BARE created during installation"
cd /opt/ethoscope-node
git remote set-url origin /srv/git/ethoscope.git
-
- #setting branch
git checkout dev
- #installing python module
- cd /opt/ethoscope-node/node_src/
- python setup.py develop
+ #installing python modules
+ cd /opt/ethoscope-node/node_src/ && python setup.py develop
+ cd /opt/ethoscope-node/src/ && python setup.py develop
echo "enabling NODE specific systemd service files"
systemctl enable ethoscope_node.service ethoscope_update_node.service ethoscope_backup.service ethoscope_video_backup.service
@@ -27,9 +29,6 @@ post_install() {
#setting host settings on node
echo "127.0.0.1 node" > /etc/hosts
- #Link scripts that need to run automatically
- ln -s /opt/ethoscope-node/node_src/scripts/make_index.py /etc/cron.daily/make_index.py
-
echo "PLEASE REBOOT NOW."
}
@@ -48,6 +47,9 @@ post_upgrade() {
#setting branch
git checkout dev
+
+ cd /opt/ethoscope-node/node_src/ && python setup.py develop
+ cd /opt/ethoscope-node/src/ && python setup.py develop
}
# arg 1: the old package version