summarylogtreecommitdiffstats
path: root/expose-cargs-and-largs-makefile.patch
diff options
context:
space:
mode:
authorRod Kay2017-06-05 14:36:37 +1000
committerRod Kay2017-06-05 14:36:37 +1000
commit52cc7570ccd11b14e81655ee545f7f5c59075f35 (patch)
treeeea3cfd00b3d20a5badf10eeb786b4313b9f6efc /expose-cargs-and-largs-makefile.patch
parenteed7d19821dc6cedf61f42c570df5e5cc9e5b5fa (diff)
downloadaur-52cc7570ccd11b14e81655ee545f7f5c59075f35.tar.gz
Update to latest git version
Diffstat (limited to 'expose-cargs-and-largs-makefile.patch')
-rw-r--r--expose-cargs-and-largs-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
new file mode 100644
index 000000000000..ee2662a64387
--- /dev/null
+++ b/expose-cargs-and-largs-makefile.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile.in b/Makefile.in
+index c6327d2..3355762 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -51,14 +51,22 @@ all: static
+ install: install-clean install-static
+ endif
+
++ifneq ($(strip $(CFLAGS)),)
++CARGS := -cargs $(CFLAGS)
++endif
++
++ifneq ($(strip $(LDFLAGS)),)
++LARGS := -largs $(LDFLAGS)
++endif
++
+ static:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+
+ shared relocatable:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+
+ static-pic:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+
+ # Rebuild the tests (and not the XML/Ada code itself)
+ test: force