summarylogtreecommitdiffstats
path: root/expose-cargs-and-largs-makefile.patch
diff options
context:
space:
mode:
authorRod Kay2022-11-15 21:40:30 +1100
committerRod Kay2022-11-15 21:40:30 +1100
commit6309b8c2b7c7af6bc491badc0a18e7d20f6f740b (patch)
tree550c1b7921ee2a593a9ee8956c3c370a5e98174e /expose-cargs-and-largs-makefile.patch
parentd4026dad434558621cadea3aa71a4954d697642a (diff)
downloadaur-6309b8c2b7c7af6bc491badc0a18e7d20f6f740b.tar.gz
Update to version '23.0.0'.
Diffstat (limited to 'expose-cargs-and-largs-makefile.patch')
-rw-r--r--expose-cargs-and-largs-makefile.patch20
1 files changed, 9 insertions, 11 deletions
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
index ee2662a64387..8cbe752d6cab 100644
--- a/expose-cargs-and-largs-makefile.patch
+++ b/expose-cargs-and-largs-makefile.patch
@@ -1,8 +1,6 @@
-diff --git a/Makefile.in b/Makefile.in
-index c6327d2..3355762 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -51,14 +51,22 @@ all: static
+--- Makefile.in-orig 2022-09-28 16:33:19.000000000 +1000
++++ Makefile.in 2022-11-15 21:15:27.002332097 +1100
+@@ -68,14 +68,22 @@
install: install-clean install-static
endif
@@ -15,16 +13,16 @@ index c6327d2..3355762 100644
+endif
+
static:
-- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr
-+ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA}
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA} $(CARGS) $(LARGS)
shared relocatable:
-- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr
-+ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA}
++ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA} $(CARGS) $(LARGS)
static-pic:
-- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr
-+ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA}
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr ${GPROPTS_EXTRA} $(CARGS) $(LARGS)
# Rebuild the tests (and not the XML/Ada code itself)
test: force