summarylogtreecommitdiffstats
path: root/expose-cargs-and-largs-makefile.patch
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2017-06-18 11:09:17 +0200
committerPierre-Marie de Rodat2017-06-18 12:34:21 +0200
commitbf263bf4fe193316228dd760c910a4f1849cc2a9 (patch)
tree62c117fc40432140865e0202e0ef6749b6d026b0 /expose-cargs-and-largs-makefile.patch
downloadaur-bf263bf4fe193316228dd760c910a4f1849cc2a9.tar.gz
Initial commit
Diffstat (limited to 'expose-cargs-and-largs-makefile.patch')
-rw-r--r--expose-cargs-and-largs-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
new file mode 100644
index 000000000000..ee2662a64387
--- /dev/null
+++ b/expose-cargs-and-largs-makefile.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile.in b/Makefile.in
+index c6327d2..3355762 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -51,14 +51,22 @@ all: static
+ install: install-clean install-static
+ endif
+
++ifneq ($(strip $(CFLAGS)),)
++CARGS := -cargs $(CFLAGS)
++endif
++
++ifneq ($(strip $(LDFLAGS)),)
++LARGS := -largs $(LDFLAGS)
++endif
++
+ static:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+
+ shared relocatable:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=relocatable ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+
+ static-pic:
+- ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr
++ ${GPRBUILD} -p -XLIBRARY_TYPE=static-pic ${GPROPTS} xmlada.gpr $(CARGS) $(LARGS)
+
+ # Rebuild the tests (and not the XML/Ada code itself)
+ test: force