summarylogtreecommitdiffstats
path: root/faad2-version-check.patch
diff options
context:
space:
mode:
authorGordonGR2015-06-28 15:44:30 +0300
committerGordonGR2015-06-28 15:44:30 +0300
commit5067205f3e107de6c9fe299b3520e82e985e9613 (patch)
tree9d108d1e28c09c7bd409cb955ceb88da146be4f6 /faad2-version-check.patch
parente5e2ed3221b0e03b1017789eb8534be8f01c30de (diff)
downloadaur-5067205f3e107de6c9fe299b3520e82e985e9613.tar.gz
On par with gstreamer0.10-bad 0.10.23-10 from [extra]
Diffstat (limited to 'faad2-version-check.patch')
-rw-r--r--faad2-version-check.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/faad2-version-check.patch b/faad2-version-check.patch
new file mode 100644
index 000000000000..aad0fb4b0439
--- /dev/null
+++ b/faad2-version-check.patch
@@ -0,0 +1,35 @@
+From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Wed, 13 May 2015 16:23:26 +0200
+Subject: fix faad2 version check
+
+On fedora 22, the output of cpp inserts extra debug comments, which
+makes our regexp for the faad2 version check fail. This in turn causes
+it to compile with the wrong arguments passed which then causes stack
+corruption and crashes.
+
+Fix this by only checking for the version (which should be by itself on
+a single line). This is potentially less safe, it might be possible that
+a similar string would appear in a later version in the header file.
+
+Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
+
+diff --git a/configure.ac b/configure.ac
+index f5ce28c..d295253 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
+ AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
+ for minor in 10 9 8 7 6 5 0; do
+ if test x$faad2_minor_version = "x"; then
+- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
++ AC_EGREP_CPP([\"2\.$minor\"$], [
+ #include <$faad_hdr>
+- GST_CHECK_FAAD_VERSION FAAD2_VERSION
++ FAAD2_VERSION
+ ], [
+ faad2_minor_version=$minor
+ ])
+--
+cgit v0.10.2
+