summarylogtreecommitdiffstats
path: root/fix-X11_keyboard-compilation.patch
diff options
context:
space:
mode:
authorKenjiTakahashi2017-02-02 04:56:24 +0100
committerKenjiTakahashi2017-02-02 04:56:24 +0100
commit0b5fb2e23cc56482985c32361145501f32547ce1 (patch)
tree500acfb7a810aa8835cea85c9335e1a823d15ece /fix-X11_keyboard-compilation.patch
parente8d35f22c9b0fd0665cae6e498bc907cbcac8be2 (diff)
downloadaur-0b5fb2e23cc56482985c32361145501f32547ce1.tar.gz
4.4.4-1: Bumped version
1. Adjusted faust patch for clang 3.9.1. 2. Adjusted vstsdk patch for upstream changes. 3. Using libxcb from [extra] to make sure we have all necessary patches. [Also makes libthread-stubs unneeded.] 4. Fixed X11_keyboard compilation flags.
Diffstat (limited to 'fix-X11_keyboard-compilation.patch')
-rw-r--r--fix-X11_keyboard-compilation.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/fix-X11_keyboard-compilation.patch b/fix-X11_keyboard-compilation.patch
new file mode 100644
index 000000000000..219dc6b94695
--- /dev/null
+++ b/fix-X11_keyboard-compilation.patch
@@ -0,0 +1,14 @@
+Only in package.new: .Makefile.Qt.swp
+diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
+--- package.pristine/Makefile.Qt 2017-02-02 01:15:50.335803833 +0100
++++ package.new/Makefile.Qt 2017-02-02 02:18:48.679033631 +0100
+@@ -1087,7 +1087,7 @@
+ $(CC) X11/X11_instrument.c $(OPT)
+
+ X11_keyboard.o: $(BUILD_DEPENDENCIES) X11/X11_keyboard.cpp
+- $(CCC) X11/X11_keyboard.cpp $(QTOPT) -DUSE_QT$(RADIUM_QT_VERSION)
++ $(CCC) X11/X11_keyboard.cpp $(CPPOPT) $(QT_CFLAGS) -DUSE_QT$(RADIUM_QT_VERSION)
+
+ #X11_MidiProperties.o: $(BUILD_DEPENDENCIES) X11/X11_MidiProperties.c
+ # $(CC) X11/X11_MidiProperties.c $(OPT)
+Only in package.new: Makefile.Qt~