summarylogtreecommitdiffstats
path: root/fix-dependencies.patch
diff options
context:
space:
mode:
authorFabian Maurer2024-01-31 19:43:14 +0100
committerFabian Maurer2024-01-31 19:43:14 +0100
commitf47d9895e772fa383f6f8216cf9fe9510fa16b9b (patch)
tree1a46418374f9f3da6714255c7f31461c4070f17b /fix-dependencies.patch
parent3b54326c7b9bd53df7414f733277ce4ebc3f1ee0 (diff)
downloadaur-f47d9895e772fa383f6f8216cf9fe9510fa16b9b.tar.gz
Fix linking with removed fmt9
Diffstat (limited to 'fix-dependencies.patch')
-rw-r--r--fix-dependencies.patch4
1 files changed, 1 insertions, 3 deletions
diff --git a/fix-dependencies.patch b/fix-dependencies.patch
index e6a6bc4bd5f2..3d0f6da10444 100644
--- a/fix-dependencies.patch
+++ b/fix-dependencies.patch
@@ -3,10 +3,8 @@ index 4de71e3..d7a0e98 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -115,6 +115,7 @@ set(LUXMARK_SRCS
- ADD_EXECUTABLE(luxmark WIN32 ${LUXMARK_SRCS})
--TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
-+TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS} /usr/lib/libfmt.so.9)
+ TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
+TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb opencolorio.a OpenImageIO_Util python3.11 blosc dl Imath)
if (WIN32)