summarylogtreecommitdiffstats
path: root/fix-flags.patch
diff options
context:
space:
mode:
authorJean Lucas2018-08-12 15:39:05 -0400
committerJean Lucas2018-08-12 15:40:54 -0400
commitc5644673946bd621a15eb64e17bca18d945970d5 (patch)
tree8ca07f51851e15ff0a47c2078372419833944d59 /fix-flags.patch
downloadaur-fcode-utils.tar.gz
Initial commit
Diffstat (limited to 'fix-flags.patch')
-rw-r--r--fix-flags.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/fix-flags.patch b/fix-flags.patch
new file mode 100644
index 000000000000..1a82fccf3ed2
--- /dev/null
+++ b/fix-flags.patch
@@ -0,0 +1,52 @@
+diff --git a/detok/Makefile b/detok/Makefile
+index e7c7c04..284c509 100644
+--- a/detok/Makefile
++++ b/detok/Makefile
+@@ -29,8 +29,8 @@ STRIP = strip
+ INCLUDES = -I../shared
+
+ # Normal Flags:
+-CFLAGS = -O2 -Wall -Wno-pointer-sign
+-LDFLAGS =
++CFLAGS := $(CFLAGS) -Wall -Wno-pointer-sign
++LDFLAGS := $(LDFLAGS)
+
+ # Coverage:
+ #CFLAGS := $(CFLAGS) -fprofile-arcs -ftest-coverage
+diff --git a/romheaders/Makefile b/romheaders/Makefile
+index 3794aeb..c0ca9b5 100644
+--- a/romheaders/Makefile
++++ b/romheaders/Makefile
+@@ -22,7 +22,7 @@
+ #
+
+ CC = gcc
+-CFLAGS= -O2 -Wall -W -ansi -I../shared
++CFLAGS := $(CFLAGS) -Wall -W -ansi -I../shared
+
+ SOURCES = romheaders.c ../shared/classcodes.c
+
+@@ -31,7 +31,7 @@ SOURCES = romheaders.c ../shared/classcodes.c
+ all: romheaders
+
+ romheaders: $(SOURCES)
+- $(CC) $(CFLAGS) $(SOURCES) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(CFLAGS) $(SOURCES) -o $@
+ strip romheaders
+
+ clean:
+diff --git a/toke/Makefile b/toke/Makefile
+index 14ae095..fa4b845 100644
+--- a/toke/Makefile
++++ b/toke/Makefile
+@@ -29,8 +29,8 @@ STRIP = strip
+ INCLUDES = -I../shared
+
+ # Normal flags
+-CFLAGS = -O2 -Wall -Wno-pointer-sign -fno-strict-aliasing
+-LDFLAGS =
++CFLAGS := $(CFLAGS) -Wall -Wno-pointer-sign -fno-strict-aliasing
++LDFLAGS := $(LDFLAGS)
+
+ # Coverage:
+ #CFLAGS := $(CFLAGS) -fprofile-arcs -ftest-coverage