summarylogtreecommitdiffstats
path: root/fix-git-rev.patch
diff options
context:
space:
mode:
authorClaudia Pellegrino2023-10-17 08:31:42 +0200
committerClaudia Pellegrino2023-10-17 11:32:29 +0200
commit61460fc67bfe6a4131628a6a31fcb5d746ff7085 (patch)
tree23f91a0dbd12b3b8cb37c432662f572453f748a9 /fix-git-rev.patch
parentb17148ff480a62a15478eb91eec298886dc59ee5 (diff)
downloadaur-61460fc67bfe6a4131628a6a31fcb5d746ff7085.tar.gz
Update to t45, thanks user @FredBezies
Also switch to clang++ as the C++ compiler in order to fix the following error message: > g++ -o x16emu build/x16emu/cpu/fake6502.o […] -flto > build/x16emu/cpu/fake6502.o: file not recognized: file format not recognized > collect2: error: ld returned 1 exit status
Diffstat (limited to 'fix-git-rev.patch')
-rw-r--r--fix-git-rev.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/fix-git-rev.patch b/fix-git-rev.patch
index 186ce1e616ba..f510297685b9 100644
--- a/fix-git-rev.patch
+++ b/fix-git-rev.patch
@@ -1,12 +1,12 @@
diff --git a/Makefile b/Makefile
-index 6b1f4fe..ee65ed2 100644
+index 3eccc85..3712f75 100644
--- a/Makefile
+++ b/Makefile
-@@ -42,7 +42,7 @@ endif
+@@ -33,7 +33,7 @@ endif
X16_OUTPUT=x16emu
MAKECART_OUTPUT=makecart
--GIT_REV=$(shell git diff --quiet && echo -n $$(git rev-parse --short=8 HEAD || /bin/echo "00000000") || /bin/echo -n $$( /bin/echo -n $$(git rev-parse --short=7 HEAD || /bin/echo "0000000"); /bin/echo -n '+'))
+-GIT_REV=$(shell git diff --quiet && /bin/echo -n $$(git rev-parse --short=8 HEAD || /bin/echo "00000000") || /bin/echo -n $$( /bin/echo -n $$(git rev-parse --short=7 HEAD || /bin/echo "0000000"); /bin/echo -n '+'))
+GIT_REV=0000000
CFLAGS+=-D GIT_REV='"$(GIT_REV)"'