summarylogtreecommitdiffstats
path: root/fix-makefile-kernelrelease.patch
diff options
context:
space:
mode:
authorChristoph Gysin2017-07-18 10:33:10 +0300
committerChristoph Gysin2017-07-18 10:48:52 +0300
commit0b231258fc5e61b91efc0b414f48029abcd538a1 (patch)
tree235c2630fc72a837d7e47cde6538177c6d943a15 /fix-makefile-kernelrelease.patch
parentd6a176e6f589e8aa67190482ad0bd46fd97a4d29 (diff)
downloadaur-0b231258fc5e61b91efc0b414f48029abcd538a1.tar.gz
resolve confilcts, patch makefile
Diffstat (limited to 'fix-makefile-kernelrelease.patch')
-rw-r--r--fix-makefile-kernelrelease.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/fix-makefile-kernelrelease.patch b/fix-makefile-kernelrelease.patch
new file mode 100644
index 000000000000..c2f05bcc9031
--- /dev/null
+++ b/fix-makefile-kernelrelease.patch
@@ -0,0 +1,23 @@
+commit 76945312a9d2e786bebc9bb5711f5962365c5c20
+Author: Joe Barnett <jbarnett@stanfordalumni.org>
+Date: Thu Apr 21 15:57:16 2016 -0700
+
+ Add dkms.conf and tweak Makefile to work with dkms
+
+ Specifically, allow building for an installed kernel that is not the running kernel
+
+diff --git a/Makefile b/Makefile
+index 0e4b2a8..0ddf666 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,10 @@
+ facetimehd-objs := fthd_ddr.o fthd_hw.o fthd_drv.o fthd_ringbuf.o fthd_isp.o fthd_v4l2.o fthd_buffer.o fthd_debugfs.o
+ obj-m := facetimehd.o
+
++KVERSION := $(KERNELRELEASE)
++ifeq ($(origin KERNELRELEASE), undefined)
+ KVERSION := $(shell uname -r)
++endif
+ KDIR := /lib/modules/$(KVERSION)/build
+ PWD := $(shell pwd)
+