summarylogtreecommitdiffstats
path: root/fix-meson-no-install.patch
diff options
context:
space:
mode:
authorJianqiu Zhang2018-08-11 10:04:47 +0800
committerJianqiu Zhang2018-08-11 10:13:46 +0800
commit0980302979182c673641b9f7ac80f3ade10ed6fe (patch)
treee1a96dd689481c840c51bd0bfec0683c3a8d479e /fix-meson-no-install.patch
downloadaur-0980302979182c673641b9f7ac80f3ade10ed6fe.tar.gz
package for oomd-git
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
Diffstat (limited to 'fix-meson-no-install.patch')
-rw-r--r--fix-meson-no-install.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/fix-meson-no-install.patch b/fix-meson-no-install.patch
new file mode 100644
index 000000000000..2e67682b4e62
--- /dev/null
+++ b/fix-meson-no-install.patch
@@ -0,0 +1,35 @@
+diff --git a/example/oomd.json b/example/oomd.json
+index 664aed5..859f4ba 100644
+--- a/example/oomd.json
++++ b/example/oomd.json
+@@ -7,7 +7,7 @@
+ {"sshd.service": { "max_usage": "inf" } }
+ ],
+ "oomdetector": "default",
+- "oomkiller": "fbje"
++ "oomkiller": "default"
+ },
+ {
+ "target": "workload.slice",
+diff --git a/meson.build b/meson.build
+index f12f067..2842453 100644
+--- a/meson.build
++++ b/meson.build
+@@ -39,14 +39,16 @@ srcs = files('''
+
+ deps = [dependency('jsoncpp'),
+ dependency('threads')]
+-oomd_lib = library('oomd',
++oomd_lib = shared_library('oomd',
+ srcs,
+ include_directories : inc,
++ install: true,
+ dependencies : deps)
+ executable('oomd_bin',
+ files('Main.cpp'),
+ include_directories : inc,
+ dependencies : deps,
++ install: true,
+ link_with : oomd_lib)
+
+ gtest_dep = dependency('gtest', main : true, required : false)