summarylogtreecommitdiffstats
path: root/fix-srcdir-reference.patch
diff options
context:
space:
mode:
authorSebastian Meyer2020-03-01 19:45:47 +0100
committerSebastian Meyer2020-03-01 20:06:27 +0100
commit9bd8d030845c89c1ae35a0432b4497cb971e8325 (patch)
tree4413f1d27ddd3a4f8f096ff133d0e64a69ff61fc /fix-srcdir-reference.patch
downloadaur-9bd8d030845c89c1ae35a0432b4497cb971e8325.tar.gz
Initial PKGBUILD for sdl12-compat
Diffstat (limited to 'fix-srcdir-reference.patch')
-rw-r--r--fix-srcdir-reference.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/fix-srcdir-reference.patch b/fix-srcdir-reference.patch
new file mode 100644
index 000000000000..f42414b9fd38
--- /dev/null
+++ b/fix-srcdir-reference.patch
@@ -0,0 +1,17 @@
+This reference to __FILE__ would include the whole $srcdir - hence triggering the
+> ==> WARNING: Package contains reference to $srcdir
+and preventing reproducible builds.
+
+diff --git a/src/SDL12_compat.c b/src/SDL12_compat.c
+index 2fb0d2c..f89e1c3 100644
+--- a/src/SDL12_compat.c
++++ b/src/SDL12_compat.c
+@@ -104,7 +104,7 @@
+ do { \
+ static SDL_bool seen = SDL_FALSE; \
+ if (!seen) { \
+- fprintf(stderr, "FIXME: %s (%s, %s:%d)\n", x, __FUNCTION__, __FILE__, __LINE__); \
++ fprintf(stderr, "FIXME: %s (%s, SDL12_compat.c:%d)\n", x, __FUNCTION__, __LINE__); \
+ seen = SDL_TRUE; \
+ } \
+ } while (0)