summarylogtreecommitdiffstats
path: root/fix_get_numpy_include.patch
diff options
context:
space:
mode:
authora8212023-08-12 09:30:15 +0200
committera8212023-08-12 09:30:15 +0200
commit05d2758e1977cbdb9cc0eea70b81ad0652f46757 (patch)
treeb8c08aa6b63f34198200d97eada802843d78f0cb /fix_get_numpy_include.patch
parenta43432bca21f15667735f39af8ff47c5a2bc2e43 (diff)
downloadaur-05d2758e1977cbdb9cc0eea70b81ad0652f46757.tar.gz
fix numpy include detection
Diffstat (limited to 'fix_get_numpy_include.patch')
-rw-r--r--fix_get_numpy_include.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/fix_get_numpy_include.patch b/fix_get_numpy_include.patch
new file mode 100644
index 000000000000..1f760c68126f
--- /dev/null
+++ b/fix_get_numpy_include.patch
@@ -0,0 +1,25 @@
+diff -ru openTSNE-1.0.0.orig/setup.py openTSNE-1.0.0/setup.py
+--- openTSNE-1.0.0.orig/setup.py 2023-08-11 13:36:22.222050683 +0200
++++ openTSNE-1.0.0/setup.py 2023-08-11 13:36:44.962034085 +0200
+@@ -55,17 +55,10 @@
+ writer.write(body, resources, nb_name)
+
+
+-class get_numpy_include:
+- """Helper class to determine the numpy include path
+-
+- The purpose of this class is to postpone importing numpy until it is
+- actually installed, so that the ``get_include()`` method can be invoked.
+-
+- """
+- def __str__(self):
+- import numpy
+- return numpy.get_include()
+-
++def get_numpy_include():
++ """get the numpy includes without wrapper class"""
++ import numpy
++ return numpy.get_include()
+
+ def get_include_dirs():
+ """Get include dirs for the compiler."""