summarylogtreecommitdiffstats
path: root/fix_setup.patch
diff options
context:
space:
mode:
authorGuillaume Horel2017-08-12 09:58:17 -0400
committerGuillaume Horel2017-08-12 09:58:17 -0400
commit28db94afc6fe5718ba679d65f768fd3ca18470f4 (patch)
tree85856511e462a1e6617a35d5f5bf2cd8d646811f /fix_setup.patch
parent464436f6e5a102919294dad383c6f30c393f22f8 (diff)
downloadaur-python-ng-numpy-randomstate.tar.gz
version bump
Diffstat (limited to 'fix_setup.patch')
-rw-r--r--fix_setup.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/fix_setup.patch b/fix_setup.patch
new file mode 100644
index 000000000000..da388dc864a0
--- /dev/null
+++ b/fix_setup.patch
@@ -0,0 +1,21 @@
+diff -urN ng-numpy-randomstate-1.13.2-orig/setup.py ng-numpy-randomstate-1.13.2/setup.py
+--- ng-numpy-randomstate-1.13.2-orig/setup.py 2017-08-12 09:31:16.987628524 -0400
++++ ng-numpy-randomstate-1.13.2/setup.py 2017-08-12 09:30:44.500099958 -0400
+@@ -37,7 +37,7 @@
+ compile_rngs = rngs[:]
+
+ extra_defs = [('_CRT_SECURE_NO_WARNINGS', '1')] if os.name == 'nt' else []
+-extra_link_args = ['/LTCG', 'Advapi32.lib', 'Kernel32.lib'] if os.name == 'nt' else []
++extra_link_args = ['/LTCG', 'Advapi32.lib', 'Kernel32.lib'] if os.name == 'nt' else ['-Wl,--strip-all']
+ base_extra_compile_args = [] if os.name == 'nt' else ['-std=c99']
+ if USE_SSE2:
+ if os.name == 'nt':
+@@ -271,8 +271,6 @@
+ classifiers=classifiers,
+ packages=find_packages(),
+ package_dir={'randomstate': './randomstate'},
+- package_data={'': ['*.c', '*.h', '*.pxi', '*.pyx', '*.pxd'],
+- 'randomstate.tests.data': ['*.csv']},
+ include_package_data=True,
+ license='NSCA',
+ author='Kevin Sheppard',