summarylogtreecommitdiffstats
path: root/fool-git-detection.patch
diff options
context:
space:
mode:
authorDrasLorus2025-03-22 23:15:16 +0100
committerDrasLorus2025-03-22 23:15:16 +0100
commit976ac4844bdbf10c5f3bb2157f2764aa3ec722a4 (patch)
treea6380a6612e5ac037714286acd83990a5c248d1f /fool-git-detection.patch
parent04220699c402c4842a20bfb6266ac667cc06756a (diff)
downloadaur-976ac4844bdbf10c5f3bb2157f2764aa3ec722a4.tar.gz
Use the source tarball instead of git
- patch to allow better handling of LDFLAGS - patch to disable git detection as it is incompatible with the AUR
Diffstat (limited to 'fool-git-detection.patch')
-rw-r--r--fool-git-detection.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/fool-git-detection.patch b/fool-git-detection.patch
new file mode 100644
index 000000000000..fe8547c3a314
--- /dev/null
+++ b/fool-git-detection.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile b/src/Makefile
+index 13b3610..3ef07f0 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -30,7 +30,7 @@ checkghcpkg=$(if $(shell ghc-pkg list --simple-output $(1)),,$(error GHC package
+ $(foreach pkg,$(GHC_PKGS),$(call checkghcpkg,$(pkg)))
+
+ # Check all submodules are initialized
+-in_git_repo=$(shell git rev-parse --is-inside-work-tree 2> /dev/null )
++in_git_repo=false # To ignore AUR git
+ ifeq ($(in_git_repo),true)
+ define SUBMOD_MSG
+ Submodule $(1) missing. Initialize with