summarylogtreecommitdiffstats
path: root/force-lib32-sdl2.patch
diff options
context:
space:
mode:
authorAndrew Whatson2018-12-09 23:51:37 +1000
committerAndrew Whatson2018-12-09 23:51:37 +1000
commitec2bffd7c2ee889c23cdcbb095322376250487e6 (patch)
tree649b07089e430ea7179d63fec82185b4f0d4a874 /force-lib32-sdl2.patch
parentde70e62e2491e30b2e83079a4142d05c2d080f81 (diff)
downloadaur-ec2bffd7c2ee889c23cdcbb095322376250487e6.tar.gz
Update for CMake build
Diffstat (limited to 'force-lib32-sdl2.patch')
-rw-r--r--force-lib32-sdl2.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/force-lib32-sdl2.patch b/force-lib32-sdl2.patch
new file mode 100644
index 000000000000..01a8aee82ca1
--- /dev/null
+++ b/force-lib32-sdl2.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 588c72a..21191a2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -133,7 +133,7 @@ if(FFMPEG)
+ endif(FFMPEG)
+
+ # SDL2 Dependency
+-find_package(SDL2 CONFIG REQUIRED)
++include(/usr/lib32/cmake/SDL2/SDL2Config.cmake)
+ if (TARGET SDL2::SDL2)
+ message(STATUS "using TARGET SDL2::SDL2")
+ target_link_libraries(FAudio PUBLIC SDL2::SDL2)