summarylogtreecommitdiffstats
path: root/foxxll_CMakeLists.txt.patch
diff options
context:
space:
mode:
authorMichael Kuc2020-12-12 18:18:55 +0000
committerMichael Kuc2020-12-12 18:18:55 +0000
commit8240cf37675b07a481c6f470126aa9c36abdb791 (patch)
tree93b2405f87c721d85ec46262216c18430cf3a797 /foxxll_CMakeLists.txt.patch
parentf5882f0357a424ae37032feb17392164e626428a (diff)
downloadaur-8240cf37675b07a481c6f470126aa9c36abdb791.tar.gz
Fix packaging issues with install directory variable expansion.
Fixes an issue with a submodule's CMakeLists. Also fixes some CMake default install path issues.
Diffstat (limited to 'foxxll_CMakeLists.txt.patch')
-rw-r--r--foxxll_CMakeLists.txt.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/foxxll_CMakeLists.txt.patch b/foxxll_CMakeLists.txt.patch
new file mode 100644
index 000000000000..e1e20223d29c
--- /dev/null
+++ b/foxxll_CMakeLists.txt.patch
@@ -0,0 +1,19 @@
+*** src/thrill/extlib/foxxll/CMakeLists.txt 2020-12-12 18:07:40.834330158 +0000
+--- CMakeLists.txt 2020-12-12 18:09:34.745282128 +0000
+***************
+*** 507,513 ****
+
+ # also copy the config file with build options!
+ install(FILES ${PROJECT_BINARY_DIR}/foxxll/config.hpp
+! DESTINATION ${INSTALL_INCLUDE_DIR}/foxxll/)
+
+ ###############################################################################
+ # prepare pkg-config file
+--- 507,513 ----
+
+ # also copy the config file with build options!
+ install(FILES ${PROJECT_BINARY_DIR}/foxxll/config.hpp
+! DESTINATION ${FOXXLL_INSTALL_INCLUDE_DIR}/foxxll/)
+
+ ###############################################################################
+ # prepare pkg-config file