summarylogtreecommitdiffstats
path: root/frosch.sh
diff options
context:
space:
mode:
authorzxp198210052023-08-04 12:26:08 +0800
committerzxp198210052023-08-04 12:26:08 +0800
commit39963b5d704fb8cef39cff6fca962bb25bce8c56 (patch)
tree75fab1895c2c39f2ded99dc653e0628fcb147175 /frosch.sh
parent5070b0a412d876eb3f6ec606b7f263770d9093f9 (diff)
downloadaur-39963b5d704fb8cef39cff6fca962bb25bce8c56.tar.gz
optimized PKGBUILD
Diffstat (limited to 'frosch.sh')
-rw-r--r--frosch.sh6
1 files changed, 4 insertions, 2 deletions
diff --git a/frosch.sh b/frosch.sh
index 162843cef01c..8b870d6f3ae5 100644
--- a/frosch.sh
+++ b/frosch.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron11
+_ASAR="/opt/frosch/frosch.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron11 /opt/frosch/frosch.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron11 --no-sandbox /opt/frosch/frosch.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file