summarylogtreecommitdiffstats
path: root/ftxui_build_docs_target_all.patch
diff options
context:
space:
mode:
authorVitalii Kuzhdin2025-01-27 16:53:00 +0100
committerVitalii Kuzhdin2025-01-27 16:53:00 +0100
commit38edf735861d796b398c85333490583f2164690c (patch)
tree11544e4c36904569b89e0987cc5e84c7e49a02cf /ftxui_build_docs_target_all.patch
parent8332edcdbaa03441155abc68fb1191dfb5e3923a (diff)
downloadaur-38edf735861d796b398c85333490583f2164690c.tar.gz
Add -ffat-lto-objects
Diffstat (limited to 'ftxui_build_docs_target_all.patch')
-rw-r--r--ftxui_build_docs_target_all.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/ftxui_build_docs_target_all.patch b/ftxui_build_docs_target_all.patch
new file mode 100644
index 000000000000..618d75742be9
--- /dev/null
+++ b/ftxui_build_docs_target_all.patch
@@ -0,0 +1,36 @@
+Description: Build docs along with library
+ There used to be the option "ALL" in the cmake custom target "doc" as
+ indicated by the comment above that custom target, which enabled building
+ docs along with the library. This was removed for some reason, perhaps to
+ build docs in a separate pipeline. This effectively renders the cmake flag
+ FTXUI_BUILD_DOCS pointless, as it does not infact build the docs.
+ Secondly, as the docs are not built with the library, they aren't installed to
+ usr/share/doc even when FTXUI_ENABLE_INSTALL is set to ON.
+ This patch adds the "ALL" option back and adds the install target for docs.
+Author: Shriram Ravindranathan <s20n@ters.dev>
+Forwarded: not-needed
+Last-Update: 2024-02-15
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/doc/CMakeLists.txt
++++ b/doc/CMakeLists.txt
+@@ -19,9 +19,18 @@
+ configure_file(Doxyfile.in Doxyfile @ONLY)
+
+ # note the option ALL which allows to build the docs together with the application
+-add_custom_target(doc
++add_custom_target(doc ALL
+ COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating API documentation with Doxygen"
+ VERBATIM
+ )
++
++if(FTXUI_ENABLE_INSTALL)
++ install(DIRECTORY ${PROJECT_BINARY_DIR}/doc/doxygen/html
++ DESTINATION ${CMAKE_INSTALL_DOCDIR}
++ COMPONENT doc)
++ install(DIRECTORY ${PROJECT_BINARY_DIR}/doc/doxygen/xml
++ DESTINATION ${CMAKE_INSTALL_DOCDIR}
++ COMPONENT doc)
++endif()