summarylogtreecommitdiffstats
path: root/fuhquake.install
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit9360a2a8020f2a4550b595c8bbd41250500fc025 (patch)
tree0e87ae096ae2cce8aa4847df2093a493a5803dd2 /fuhquake.install
downloadaur-9360a2a8020f2a4550b595c8bbd41250500fc025.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
Diffstat (limited to 'fuhquake.install')
-rw-r--r--fuhquake.install33
1 files changed, 33 insertions, 0 deletions
diff --git a/fuhquake.install b/fuhquake.install
new file mode 100644
index 000000000000..a137f577e3f1
--- /dev/null
+++ b/fuhquake.install
@@ -0,0 +1,33 @@
+
+post_install() {
+ echo ">>> You need the retail pak0.pak and pak1.pak in order to play."
+ echo ">>> Copy or symlink them to /opt/quake/id/"
+ echo ">>>"
+ echo ">>> You must also add your user to the 'games' group."
+ echo ">>>"
+ echo ">>> # gpasswd -a USERNAME games"
+ echo ">>>"
+ echo ">>> After configuring your keys and settings, save your config with"
+ echo ">>> the following command in the console: "
+ echo ">>>"
+ echo ">>> /cfg_save USERNAME"
+ echo ">>>"
+ echo ">>> Where USERNAME is what 'whoami' returns in a terminal. Everytime "
+ echo ">>> fuhQuake starts it will attempt to automatically load USERNAME.cfg"
+ echo ">>>"
+ echo ">>> You can play on any QuakeWorld servers with fuhQuake. Use a server"
+ echo ">>> browser to find games, such as XQF."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*