summarylogtreecommitdiffstats
path: root/funguloids-lua.patch
diff options
context:
space:
mode:
authorNicolas Iooss2016-06-17 21:36:34 +0200
committerNicolas Iooss2016-06-17 21:36:34 +0200
commit253d319b723a50394284b0aaae8dad279f10fb16 (patch)
tree5788a3093b3d72d363c3898228625a517439ae05 /funguloids-lua.patch
parent4f1ba6bbd688961f6890d4ad48cf48adafaf3911 (diff)
downloadaur-253d319b723a50394284b0aaae8dad279f10fb16.tar.gz
funguloids 1.06.4-8 update: fix lua51 dependency
Since commit https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/lua51&id=d46f4b70dab932996805f93dd386417b86021eb2 lua51 installed its pkg-config file as "lua51.pc" instead of "lua5.1.pc". Update the Lua detection logic.
Diffstat (limited to 'funguloids-lua.patch')
-rw-r--r--funguloids-lua.patch7
1 files changed, 4 insertions, 3 deletions
diff --git a/funguloids-lua.patch b/funguloids-lua.patch
index 7762533e6eab..e7651c081d0b 100644
--- a/funguloids-lua.patch
+++ b/funguloids-lua.patch
@@ -1,6 +1,6 @@
--- configure.ac
+++ configure.ac
-@@ -47,30 +47,11 @@
+@@ -47,30 +47,13 @@
# LUA ----------------------------------------------------
@@ -20,10 +20,11 @@
- PKG_CHECK_MODULES(LUA, [lua >= 5.1],[],[
- PKG_CHECK_MODULES(LUA, [lua5.1 >= 5.1],[],[
- AC_MSG_ERROR(Lua 5.1 not found. You can specify its location with [[--with-lua=/path/to/include/lua51]])
-- ])
+PKG_CHECK_MODULES(LUA, [lua >= 5.1, lua < 5.2],[],[
+ PKG_CHECK_MODULES(LUA, [lua5.1 >= 5.1],[],[
-+ AC_MSG_ERROR(Lua 5.1 not found)
++ PKG_CHECK_MODULES(LUA, [lua51 >= 5.1, lua51 < 5.2],[],[
++ AC_MSG_ERROR(Lua 5.1 not found)
+ ])
])
-else
- CFLAGS="$CFLAGS $FUNGU_FOUND_HEADER"