summarylogtreecommitdiffstats
path: root/gcc8.patch
diff options
context:
space:
mode:
authorb3niup2018-06-13 08:57:09 +0200
committerb3niup2018-06-13 08:57:09 +0200
commitccd54dc6daec53366538ad7e3ce3e5264acb6fc2 (patch)
tree66d3fbc60822a7e261c4d3d299645c5c588e2f0a /gcc8.patch
parent7db54d30129229b05fb8db07544547789a4d396b (diff)
downloadaur-ccd54dc6daec53366538ad7e3ce3e5264acb6fc2.tar.gz
Add workaround for gtk warnings with gcc 8.0 and cosmetic changes.
Diffstat (limited to 'gcc8.patch')
-rw-r--r--gcc8.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gcc8.patch b/gcc8.patch
new file mode 100644
index 000000000000..064df51fc24c
--- /dev/null
+++ b/gcc8.patch
@@ -0,0 +1,13 @@
+--- CMakeLists.txt 2018-06-13 08:20:55.012756800 +0200
++++ CMakeLists.txt 2018-06-13 08:23:34.179228185 +0200
+@@ -551,8 +551,8 @@
+
+ IF (UNIX)
+ SET( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
+- SET( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused ${CMAKE_CXX_FLAGS}")
+- SET( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 ${CMAKE_C_FLAGS}")
++ SET( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
++ SET( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 -Wno-error=parentheses ${CMAKE_C_FLAGS}")
+ SET( CMAKE_C_FLAGS_RELEASE "-O3 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
+ ENDIF (UNIX)
+ IF (MINGW)