summarylogtreecommitdiffstats
path: root/generate_patches
diff options
context:
space:
mode:
authorIliya Ivanov2019-03-26 10:50:09 +0200
committerIliya Ivanov2019-03-26 10:50:09 +0200
commit222df2bee7f241b970690d3bd9984b3ee53656f6 (patch)
tree44b248bf45f3e910895afd2296696eb911be5473 /generate_patches
parentd78c0c0ca4a82a90f862fe3338ab4a14178c88c2 (diff)
downloadaur-222df2bee7f241b970690d3bd9984b3ee53656f6.tar.gz
Bump PHP version and fixes
Diffstat (limited to 'generate_patches')
-rwxr-xr-xgenerate_patches11
1 files changed, 1 insertions, 10 deletions
diff --git a/generate_patches b/generate_patches
index 2a64a44fd62d..8567951594b3 100755
--- a/generate_patches
+++ b/generate_patches
@@ -4,18 +4,10 @@
makepkg -o --nodeps --noprepare --skipinteg
-pushd src/${_pkgbase}-${pkgver}
+pushd src/${pkgbase}-${pkgver}
sed '/APACHE_THREADED_MPM=/d' -i.orig sapi/apache2handler/config.m4
-sed \
- -e '/APACHE_THREADED_MPM=/d' \
- -e '/elif test -f $i\/include\/enchant.h; then/i\\t\telif test -f $i/include/enchant-2/enchant.h; then\n\t\t\tENCHANT_DIR=$i\n\t\t\tENCHANT_INCDIR=$i/include/enchant-2' \
- -e '/for i in $PHP_FREETYPE_DIR \/usr\/local \/usr; do/a\\n\tif test -d "$i/include/freetype2"; then\n\t\tFREETYPE2_DIR=$i/include/freetype2\n\t\tFREETYPE2_CONFIG="pkg-config freetype2"' \
- -e '/if test -f "$i\/bin\/freetype-config"; then/, +2d' \
- -e '/freetype-config not found/c\\t\tas_fn_error $? "freetype2 not found." "$LINENO" 5' \
- -i.orig configure
-
sed 's/.conf.default/.conf/g' -i.orig sapi/fpm/Makefile.frag
sed \
@@ -44,7 +36,6 @@ sed \
-i php.ini-production
diff -u sapi/apache2handler/config.m4.orig sapi/apache2handler/config.m4 | filterdiff --clean --remove-timestamps > ../../apache.patch
-diff -u configure.orig configure | filterdiff --clean --remove-timestamps >> ../../apache.patch
diff -u sapi/fpm/Makefile.frag.orig sapi/fpm/Makefile.frag | filterdiff --clean --remove-timestamps > ../../php-fpm.patch
diff -u sapi/fpm/php-fpm.conf.in.orig sapi/fpm/php-fpm.conf.in | filterdiff --clean --remove-timestamps >> ../../php-fpm.patch