summarylogtreecommitdiffstats
path: root/gltron-0.70-debian.patch
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit1417be7776321c28b1bb45346d13b2f50043f6f6 (patch)
tree9c932e55aed6a66997cf9d87dffdecefe942dd2a /gltron-0.70-debian.patch
downloadaur-1417be7776321c28b1bb45346d13b2f50043f6f6.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'gltron-0.70-debian.patch')
-rw-r--r--gltron-0.70-debian.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gltron-0.70-debian.patch b/gltron-0.70-debian.patch
new file mode 100644
index 000000000000..464cf5928207
--- /dev/null
+++ b/gltron-0.70-debian.patch
@@ -0,0 +1,35 @@
+Ripped from Debian patchset 6
+
+--- src/include/game/game_data.h
++++ src/include/game/game_data.h
+@@ -71,7 +71,7 @@
+ typedef struct AI {
+ int active;
+ int tdiff;
+- long lasttime;
++ unsigned int lasttime;
+ segment2 left, right, front, backleft;
+ } AI;
+
+--- src/include/video/fonttex.h
++++ src/include/video/fonttex.h
+@@ -10,7 +10,7 @@
+ int lower; /* lowest ascii character (normally: 32) */
+ int upper; /* highest ascii character (normally: 126) */
+
+- int *texID;
++ unsigned int *texID;
+
+ char *fontname;
+ char *bitmapname;
+--- src/video/trail.c
++++ src/video/trail.c
+@@ -19,7 +19,7 @@
+ n[1] = s->vStart.v[1] - s->vDirection.v[0];
+ tmp[0] = eye[0] - s->vStart.v[0];
+ tmp[1] = eye[1] - s->vStart.v[1];
+- if(n[0] == n[1] == 0) return length(tmp);
++ if(n[0] == 0 && n[1] == 0) return length(tmp);
+ return abs(scalarprod2(n, tmp) / length(n));
+ }
+