summarylogtreecommitdiffstats
path: root/gnupg-large-rsa-2.1.6.patch
diff options
context:
space:
mode:
author“0xReki”2015-07-05 15:58:42 +0200
committer“0xReki”2015-07-05 15:58:42 +0200
commitc4ca3338448aa773934fd3b0ded52eb776885a9d (patch)
tree1aadafd33c1a6c8fed538d5cb77a3a3ba5a3ac30 /gnupg-large-rsa-2.1.6.patch
parentbc11e3316ef7bd0e65f788b3d0faddc9303fe26b (diff)
downloadaur-c4ca3338448aa773934fd3b0ded52eb776885a9d.tar.gz
pushed to 2.1.6
Diffstat (limited to 'gnupg-large-rsa-2.1.6.patch')
-rw-r--r--gnupg-large-rsa-2.1.6.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnupg-large-rsa-2.1.6.patch b/gnupg-large-rsa-2.1.6.patch
new file mode 100644
index 000000000000..538f08c2012b
--- /dev/null
+++ b/gnupg-large-rsa-2.1.6.patch
@@ -0,0 +1,53 @@
+diff -ru gnupg-2.1.5/configure gnupg-2.1.5-patched/configure
+--- gnupg-2.1.5/configure 2015-06-11 14:44:30.000000000 +0200
++++ gnupg-2.1.5-patched/configure 2015-06-27 02:34:10.326765711 +0200
+@@ -2840,7 +2840,7 @@
+
+ ac_config_headers="$ac_config_headers config.h"
+
+-am__api_version='1.14'
++am__api_version='1.15'
+
+ # Find a good install program. We prefer a C program (faster),
+ # so one script is as good as another. But avoid the broken or
+diff -ru gnupg-2.1.5/configure.ac gnupg-2.1.5-patched/configure.ac
+--- gnupg-2.1.5/configure.ac 2015-06-09 13:38:14.000000000 +0200
++++ gnupg-2.1.5-patched/configure.ac 2015-06-27 02:34:10.326765711 +0200
+@@ -19,7 +19,7 @@
+
+ # Process this file with autoconf to produce a configure script.
+ AC_PREREQ(2.61)
+-min_automake_version="1.14"
++min_automake_version="1.15"
+
+ # To build a release you need to create a tag with the version number
+ # (git tag -s gnupg-2.n.m) and run "./autogen.sh --force". Please
+@@ -229,7 +229,7 @@
+ large_secmem=$enableval, large_secmem=no)
+ AC_MSG_RESULT($large_secmem)
+ if test "$large_secmem" = yes ; then
+- SECMEM_BUFFER_SIZE=65536
++ SECMEM_BUFFER_SIZE=67108864
+ else
+ SECMEM_BUFFER_SIZE=32768
+ fi
+diff -ru gnupg-2.1.5/g10/keygen.c gnupg-2.1.5-patched/g10/keygen.c
+--- gnupg-2.1.5/g10/keygen.c 2015-06-02 17:47:50.000000000 +0200
++++ gnupg-2.1.5-patched/g10/keygen.c 2015-06-27 02:34:10.326765711 +0200
+@@ -1553,7 +1553,7 @@
+ int err;
+ char *keyparms;
+ char nbitsstr[35];
+- const unsigned maxsize = (opt.flags.large_rsa ? 8192 : 4096);
++ const unsigned maxsize = (opt.flags.large_rsa ? 14336 : 4096);
+
+ assert (is_RSA(algo));
+
+@@ -2047,6 +2047,7 @@
+
+ case PUBKEY_ALGO_RSA:
+ min=1024;
++ max = (opt.flags.large_rsa ? 14336 : 4096);
+ break;
+ }
+