summarylogtreecommitdiffstats
path: root/gtest.patch
diff options
context:
space:
mode:
authorbartus2016-10-18 01:12:51 +0200
committerbartus2016-10-18 01:12:51 +0200
commit0fe99ab2c005840d716201850448980f707e5be5 (patch)
treebddefe4c530a95db0450f8f6301aa3a20d48c5cb /gtest.patch
downloadaur-0fe99ab2c005840d716201850448980f707e5be5.tar.gz
initial commit
Diffstat (limited to 'gtest.patch')
-rw-r--r--gtest.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gtest.patch b/gtest.patch
new file mode 100644
index 000000000000..ef3950eb67b9
--- /dev/null
+++ b/gtest.patch
@@ -0,0 +1,16 @@
+diff --git a/tests/Makefile b/tests/Makefile
+index f179d48..8927a5c 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -7,9 +7,9 @@ SOURCES = $(wildcard math/gtest_*.cc) $(wildcard mve/gtest_*.cc) $(wildcard sfm/
+ INCLUDES = -I${MVE_ROOT}/libs -I${GTEST_PATH}/include
+ CXXWARNINGS = -Wall -Wextra -pedantic -Wno-sign-compare
+ CXXFLAGS = -std=c++11 -pthread ${CXXWARNINGS} ${INCLUDES}
+-LDLIBS += -lpng -ltiff -ljpeg
++LDLIBS += -lpng -ltiff -ljpeg -lgtest -lgtest_main
+
+-test: ${SOURCES:.cc=.o} libmve_fssr.a libmve_sfm.a libmve.a libmve_util.a gtest_main.a
++test: ${SOURCES:.cc=.o} libmve_fssr.a libmve_sfm.a libmve.a libmve_util.a
+ ${LINK.cc} -o $@ $^ ${LDLIBS}
+
+ clean: