summarylogtreecommitdiffstats
path: root/gtest.patch
diff options
context:
space:
mode:
authorbartus2016-11-08 20:50:56 +0100
committerbartus2016-11-08 20:50:56 +0100
commitf2768fd1aaa61a8e6533a994edf180111fc782ba (patch)
treec8036262faf1f36652a0f86b6ca9fbd197672625 /gtest.patch
parentd1a9141ba86a125a639783b9dcf2ba41d4f7e7db (diff)
downloadaur-f2768fd1aaa61a8e6533a994edf180111fc782ba.tar.gz
include Shading-aware Multi-view Stereo reconstruction
Diffstat (limited to 'gtest.patch')
-rw-r--r--gtest.patch47
1 files changed, 45 insertions, 2 deletions
diff --git a/gtest.patch b/gtest.patch
index ef3950eb67b9..04cc4492aac4 100644
--- a/gtest.patch
+++ b/gtest.patch
@@ -1,7 +1,7 @@
diff --git a/tests/Makefile b/tests/Makefile
index f179d48..8927a5c 100644
---- a/tests/Makefile
-+++ b/tests/Makefile
+--- a/mve-git/tests/Makefile
++++ b/mve-git/tests/Makefile
@@ -7,9 +7,9 @@ SOURCES = $(wildcard math/gtest_*.cc) $(wildcard mve/gtest_*.cc) $(wildcard sfm/
INCLUDES = -I${MVE_ROOT}/libs -I${GTEST_PATH}/include
CXXWARNINGS = -Wall -Wextra -pedantic -Wno-sign-compare
@@ -14,3 +14,46 @@ index f179d48..8927a5c 100644
${LINK.cc} -o $@ $^ ${LDLIBS}
clean:
+diff --git a/tests/Makefile b/tests/Makefile
+index 69269b6..e043727 100644
+--- a/smvs/tests/Makefile
++++ b/smvs/tests/Makefile
+@@ -6,9 +6,9 @@ SOURCES = $(wildcard gtest_*.cc)
+ INCLUDES = -I../lib -I${MVE_ROOT}/libs -I${GTEST_PATH}/include
+ CXXWARNINGS = -Wall -Wextra -pedantic -Wno-sign-compare
+ CXXFLAGS = -std=c++11 -pthread ${CXXWARNINGS} ${INCLUDES}
+-LDLIBS += -lpng -ltiff -ljpeg
++LDLIBS += -lpng -ltiff -ljpeg -lgtest -lgtest_main
+
+-test: ${SOURCES:.cc=.o} libsmvs.a gtest_main.a
++test: ${SOURCES:.cc=.o} libsmvs.a
+ ${LINK.cc} -o $@ $^ ${LDLIBS}
+
+ clean:
+diff --git a/smvs/tests/gtest_correspondence.cc b/tests/gtest_correspondence.cc
+index fcb6a50..a8e2da4 100644
+--- a/smvs/tests/gtest_correspondence.cc
++++ b/smvs/tests/gtest_correspondence.cc
+@@ -365,8 +365,8 @@ TEST(CorrespondenceJacobianTest, ValuesAndDerivatives)
+ corr_new[0] -= 0.5;
+ corr_new[1] -= 0.5;
+ diff = (corr_new - corr_base) / delta;
+- EXPECT_NEAR(corr_jac[0], diff[0], 1e-4);
+- EXPECT_NEAR(corr_jac[1], diff[1], 1e-4);
++ EXPECT_NEAR(corr_jac[0], diff[0], 2e-4);
++ EXPECT_NEAR(corr_jac[1], diff[1], 2e-4);
+ x = backup;
+
+ backup = y;
+@@ -377,8 +377,8 @@ TEST(CorrespondenceJacobianTest, ValuesAndDerivatives)
+ corr_new[0] -= 0.5;
+ corr_new[1] -= 0.5;
+ diff = (corr_new - corr_base) / delta;
+- EXPECT_NEAR(corr_jac[2], diff[0], 1e-4);
+- EXPECT_NEAR(corr_jac[3], diff[1], 1e-4);
++ EXPECT_NEAR(corr_jac[2], diff[0], 2e-4);
++ EXPECT_NEAR(corr_jac[3], diff[1], 2e-4);
+ y = backup;
+
+ #if 1
+