summarylogtreecommitdiffstats
path: root/htop-temperature-rpi.patch
diff options
context:
space:
mode:
authorDX372020-08-31 16:12:29 +0700
committerDX372020-08-31 16:12:29 +0700
commit165894ffaa940e7b90ccd20054e33532a0bd84e0 (patch)
tree22bd743137423e059da462204c0867bfe4bfebd5 /htop-temperature-rpi.patch
parent8184835952b69ce5c50a15432cae848f42256275 (diff)
downloadaur-165894ffaa940e7b90ccd20054e33532a0bd84e0.tar.gz
fixes
Diffstat (limited to 'htop-temperature-rpi.patch')
-rw-r--r--htop-temperature-rpi.patch48
1 files changed, 24 insertions, 24 deletions
diff --git a/htop-temperature-rpi.patch b/htop-temperature-rpi.patch
index 18d8ec75551e..3c36c76736e6 100644
--- a/htop-temperature-rpi.patch
+++ b/htop-temperature-rpi.patch
@@ -86,12 +86,33 @@ index 5fb2f09..fc40b2a 100644
SWAP,
PROCESS,
PROCESS_SHADOW,
+diff --git a/Makefile.am b/Makefile.am
+index d455b4d..2f6dd75 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -49,6 +49,7 @@ linux_platform_headers = \
+ linux/LinuxProcessList.h \
+ linux/LinuxCRT.h \
+ linux/Battery.h \
++ TemperatureMeter.h \
+ linux/PressureStallMeter.h \
+ zfs/ZfsArcMeter.h \
+ zfs/ZfsCompressedArcMeter.h \
+@@ -59,7 +60,7 @@ all_platform_headers += $(linux_platform_headers)
+ if HTOP_LINUX
+ AM_LDFLAGS += -rdynamic
+ myhtopplatsources = linux/Platform.c linux/IOPriorityPanel.c linux/IOPriority.c \
+-linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c \
++linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c TemperatureMeter.c \
+ linux/PressureStallMeter.c \
+ zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c
+
diff --git a/TemperatureMeter.c b/TemperatureMeter.c
new file mode 100644
-index 0000000..9ee9185
+index 0000000..872b92c
--- /dev/null
+++ b/TemperatureMeter.c
-@@ -0,0 +1,100 @@
+@@ -0,0 +1,85 @@
+/*
+htop - TemperatureMeter.c
+(C) 2013 Ralf Stemmer
@@ -202,27 +223,6 @@ index 0000000..b86ddd8
+extern MeterClass TemperatureMeter_class;
+
+#endif
-diff --git a/Makefile.am b/Makefile.am
-index d455b4d..2f6dd75 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -49,6 +49,7 @@ linux_platform_headers = \
- linux/LinuxProcessList.h \
- linux/LinuxCRT.h \
- linux/Battery.h \
-+ TemperatureMeter.h \
- linux/PressureStallMeter.h \
- zfs/ZfsArcMeter.h \
- zfs/ZfsCompressedArcMeter.h \
-@@ -59,7 +60,7 @@ all_platform_headers += $(linux_platform_headers)
- if HTOP_LINUX
- AM_LDFLAGS += -rdynamic
- myhtopplatsources = linux/Platform.c linux/IOPriorityPanel.c linux/IOPriority.c \
--linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c \
-+linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c TemperatureMeter.c \
- linux/PressureStallMeter.c \
- zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c
-
diff --git a/linux/Platform.c b/linux/Platform.c
index 0f59fed..49038b2 100644
--- a/linux/Platform.c
@@ -232,7 +232,7 @@ index 0f59fed..49038b2 100644
#include "zfs/ZfsCompressedArcMeter.h"
#include "LinuxProcess.h"
+#include "TemperatureMeter.h"
-
+
#include <math.h>
#include <assert.h>
@@ -119,6 +120,7 @@ MeterClass* Platform_meterTypes[] = {