summarylogtreecommitdiffstats
path: root/icuinfo.makefile
diff options
context:
space:
mode:
authorTed Alff2015-07-28 19:45:27 -0400
committerTed Alff2015-07-28 19:45:27 -0400
commita046f687de20903124480f406b3a89c7b62f2f76 (patch)
tree7074d1b25ae6375d316a46920786cd1ee0ccdd8f /icuinfo.makefile
downloadaur-a046f687de20903124480f406b3a89c7b62f2f76.tar.gz
Initial AUR4 import
Diffstat (limited to 'icuinfo.makefile')
-rw-r--r--icuinfo.makefile113
1 files changed, 113 insertions, 0 deletions
diff --git a/icuinfo.makefile b/icuinfo.makefile
new file mode 100644
index 000000000000..847d660603ac
--- /dev/null
+++ b/icuinfo.makefile
@@ -0,0 +1,113 @@
+## Makefile.in for ICU - tools/icuinfo
+## Copyright (c) 1999-2010, International Business Machines Corporation and
+## others. All Rights Reserved.
+## Madhu Katragadda
+
+## Source directory information
+srcdir = .
+top_srcdir = ../..
+
+top_builddir = ../..
+
+include $(top_builddir)/icudefs.mk
+
+## Build directory information
+subdir = tools/icuinfo
+
+## Extra files to remove for 'make clean'
+CLEANFILES = *~ $(DEPS) $(PLUGIN_OBJECTS) $(PLUGINFILE) $(PLUGIN)
+
+## Target information
+TARGET = icuinfo$(EXEEXT)
+
+ifneq ($(top_builddir),$(top_srcdir))
+CPPFLAGS += -I$(top_builddir)/common
+endif
+CPPFLAGS += -I$(top_srcdir)/common -I$(srcdir)/../toolutil -I$(top_srcdir)/tools/ctestfw
+CPPFLAGS+= -I$(top_srcdir)/i18n
+LIBS = $(LIBCTESTFW) $(LIBICUTOOLUTIL) $(LIBICUI18N) $(LIBICUUC) $(DEFAULT_LIBS) $(LIB_M)
+
+OBJECTS = icuinfo.o
+PLUGIN_OBJECTS = testplug.o
+
+DEPS = $(OBJECTS:.o=.d)
+
+# pass some information
+
+ICUINFO_OPTS=-i ../../data/out/build/$(ICUDATA_PLATFORM_NAME)
+
+CPPFLAGS+= -DU_PLATFORM=\"U_LINUX\" -DU_BUILD=\"x86_64-unknown-linux-gnu\" -DU_HOST=\"x86_64-unknown-linux-gnu\"
+# -DENABLE_RELEASE=1 -DENABLE_DEBUG=0 "
+
+
+## List of phony targets
+.PHONY : all all-local install install-local clean clean-local \
+distclean distclean-local dist dist-local check check-local plugin-check
+
+## Clear suffix list
+.SUFFIXES :
+
+## List of standard targets
+all: all-local
+install: install-local
+clean: clean-local
+distclean : distclean-local
+dist: dist-local
+check: all check-local
+
+all-local: $(TARGET)
+
+install-local: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ $(INSTALL) $(TARGET) $(DESTDIR)$(bindir)
+
+dist-local:
+
+clean-local:
+ test -z "$(CLEANFILES)" || $(RMV) $(CLEANFILES)
+ $(RMV) $(TARGET) $(OBJECTS)
+
+distclean-local: clean-local
+ $(RMV) Makefile
+
+check-local: $(TARGET)
+ $(INVOKE) ./$(TARGET) $(ICUINFO_OPTS)
+
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+-include Makefile.local
+
+$(TARGET) : $(OBJECTS)
+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+ $(POST_BUILD_STEP)
+
+PLUGIN=$(LIBPREFIX)plugin.$(SO)
+SO_TARGET=$(PLUGIN)
+
+PLUGINDIR=$(shell pwd)
+
+PLUGINFILE=$(PLUGINDIR)/icuplugins$(SO_TARGET_VERSION_MAJOR).txt
+
+$(PLUGINFILE): Makefile
+ echo "$(CURR_FULL_DIR)/$(PLUGIN) myPlugin x=4" > $@
+
+CFLAGS+=$(SHAREDLIBCFLAGS)
+
+$(PLUGIN): $(PLUGIN_OBJECTS)
+ $(SHLIB.cc) $(SHAREDLIBCFLAGS) $(LD_SONAME) $(OUTOPT)$@ $^ $(LIBS)
+
+plugin: $(PLUGIN)
+
+plugin-check: $(PLUGIN) $(PLUGINFILE)
+ $(INVOKE) ICU_PLUGINS="$(CURR_FULL_DIR)" ./$(TARGET) -v -L
+
+
+ifeq (,$(MAKECMDGOALS))
+-include $(DEPS)
+else
+ifneq ($(patsubst %clean,,$(MAKECMDGOALS)),)
+-include $(DEPS)
+endif
+endif
+