summarylogtreecommitdiffstats
path: root/in-source-build.diff
diff options
context:
space:
mode:
authorTwoFinger2023-08-02 10:00:21 +0800
committerTwoFinger2023-08-02 18:08:21 +0800
commitbde63a41e15a7b515df39c67291279cd91dac265 (patch)
treec48059f2b7e452105c0b11fbe58feb3ee4e79384 /in-source-build.diff
parent2b4c4a18a558c352ad05afa9a0d6951c930334a9 (diff)
downloadaur-bde63a41e15a7b515df39c67291279cd91dac265.tar.gz
version 12.0
Diffstat (limited to 'in-source-build.diff')
-rw-r--r--in-source-build.diff65
1 files changed, 0 insertions, 65 deletions
diff --git a/in-source-build.diff b/in-source-build.diff
deleted file mode 100644
index 22de2ddd2caf..000000000000
--- a/in-source-build.diff
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/Makefile 2023-02-12 11:08:23.133779767 +0800
-+++ b/Makefile 2023-02-12 11:13:08.907691463 +0800
-@@ -225,22 +225,22 @@
-
- # Executables.
-
--linux_exes := $(addprefix ../, textadept textadept-curses)
-+linux_exes := textadept textadept-curses
- win_exes := $(addprefix ../, textadept.exe textadept-curses.exe)
- osx_exes := $(addprefix ../, textadept-osx textadept-osx-curses)
-
- .PHONY: all curses win osx
- .DEFAULT_GOAL := all
- all: $(linux_exes)
--curses: ../textadept-curses
-+curses: textadept-curses
- win: $(win_exes)
- osx: $(osx_exes)
-
- # Compile natively for Linux or BSD.
-
- $(linux_exes): $(common_objs)
--../textadept: $(gui_objs)
--../textadept-curses: $(curses_objs) $(termkey_unix_objs)
-+textadept: $(gui_objs)
-+textadept-curses: $(curses_objs) $(termkey_unix_objs)
-
- ifeq (Linux, $(shell uname -s))
- $(linux_exes): CXX := g++
-@@ -252,11 +252,11 @@
- $(linux_exes): LDFLAGS += -Wl,--retain-symbols-file -Wl,$(shell pwd)/lua.sym
- endif
- ifdef GTK2
--../textadept: LDFLAGS += $(shell pkg-config --libs gtk+-2.0 gmodule-2.0)
-+textadept: LDFLAGS += $(shell pkg-config --libs gtk+-2.0 gmodule-2.0)
- else
--../textadept: LDFLAGS += $(shell pkg-config --libs gtk+-3.0 gmodule-2.0)
-+textadept: LDFLAGS += $(shell pkg-config --libs gtk+-3.0 gmodule-2.0)
- endif
--../textadept-curses: LDFLAGS += $(shell pkg-config --silence-errors --libs ncursesw || \
-+textadept-curses: LDFLAGS += $(shell pkg-config --silence-errors --libs ncursesw || \
- pkg-config --silence-errors --libs ncurses || pkg-config --silence-errors --libs curses || \
- echo -lncursesw) -lpthread
- ifeq (Linux, $(shell uname -s))
-@@ -312,9 +312,9 @@
- PIXMAPS_DIR ?= /usr/share/pixmaps
- desktop_files := $(wildcard *.desktop)
- ifeq (, $(findstring curses, $(MAKECMDGOALS)))
-- install_targets := ../textadept
-+ install_targets := textadept
- else
-- install_targets := ../textadept-curses
-+ install_targets := textadept-curses
- endif
-
- .PHONY: install uninstall
-@@ -322,7 +322,7 @@
- install -d $(DESTDIR)$(bin_dir) $(DESTDIR)$(data_dir)
- install $^ $(DESTDIR)$(data_dir)
- cp -rL $| $(DESTDIR)$(data_dir)
-- ln -s $(subst .., $(data_dir), $^) $(DESTDIR)$(bin_dir)
-+ ln -s $(data_dir)/$^ $(DESTDIR)$(bin_dir)
- if [ -d "$(XDG_DATA_DIR)" ]; then \
- install -d $(DESTDIR)$(XDG_DATA_DIR); \
- install $(desktop_files) $(DESTDIR)$(XDG_DATA_DIR); \