summarylogtreecommitdiffstats
path: root/install-location.patch
diff options
context:
space:
mode:
authorFrank Boerman2021-01-13 22:26:59 +0100
committerFrank Boerman2021-01-13 22:26:59 +0100
commite65730da4b22158c4848490d2e3a26bc0ba2f6d6 (patch)
treee806fabf6fa2ff2a033e2f3aa6fab10afea7550a /install-location.patch
parent202684dc6ff76c77a9b1bee099d61859f2f331ba (diff)
downloadaur-libroboint.tar.gz
added udev rules to the package
Diffstat (limited to 'install-location.patch')
-rw-r--r--install-location.patch14
1 files changed, 13 insertions, 1 deletions
diff --git a/install-location.patch b/install-location.patch
index a5e8225a5fe9..88b78159b262 100644
--- a/install-location.patch
+++ b/install-location.patch
@@ -1,3 +1,16 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 581d7f5..6546f2d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -73,7 +73,7 @@ ELSE (DOXYGEN_INSTALLED)
+ MESSAGE(STATUS "Unable to create documentation!")
+ ENDIF (DOXYGEN_INSTALLED)
+
+-ADD_CUSTOM_TARGET(udev COMMAND ${CMAKE_COMMAND} -E copy udev/fischertechnik.rules /etc/udev/rules.d/fischertechnik.rules)
++ADD_CUSTOM_TARGET(udev COMMAND ${CMAKE_COMMAND} -E copy udev/fischertechnik.rules ${CMAKE_INSTALL_PREFIX}/etc/udev/rules.d/fischertechnik.rules)
+
+ ADD_DEFINITIONS(-DLIBROBOINT_VERSION_MAJOR=${CPACK_PACKAGE_VERSION_MAJOR})
+ ADD_DEFINITIONS(-DLIBROBOINT_VERSION_MINOR=${CPACK_PACKAGE_VERSION_MINOR})
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 878e901..8e060b7 100644
--- a/lib/CMakeLists.txt
@@ -23,4 +36,3 @@ index 8b3f3d5..337aacc 100644
-INSTALL_TARGETS(/bin ftuploader)
+INSTALL_TARGETS(/usr/bin ftuploader)
-