summarylogtreecommitdiffstats
path: root/jasper.patch
diff options
context:
space:
mode:
authorjose17112019-03-24 22:00:27 +0100
committerjose17112019-03-24 22:00:41 +0100
commitc24f149ff4ca2cb26e1f6eba4efacfdf080ea7e2 (patch)
treec6d914069ea7e2fa3bc820adc9fea458f41aaeb1 /jasper.patch
parent049e44833bd038d5bcbb0c460633c650cff0716a (diff)
downloadaur-c24f149ff4ca2cb26e1f6eba4efacfdf080ea7e2.tar.gz
Update
Diffstat (limited to 'jasper.patch')
-rw-r--r--jasper.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/jasper.patch b/jasper.patch
new file mode 100644
index 000000000000..7f87deb9ecaf
--- /dev/null
+++ b/jasper.patch
@@ -0,0 +1,24 @@
+diff -aur src.orig/k2pdfopt_v2.51/CMakeLists.txt src/k2pdfopt_v2.51/CMakeLists.txt
+--- src.orig/k2pdfopt_v2.51/CMakeLists.txt 2019-03-24 21:45:17.683484849 +0100
++++ src/k2pdfopt_v2.51/CMakeLists.txt 2019-03-24 21:46:17.443514984 +0100
+@@ -5,7 +5,7 @@
+
+ include(FindPkgConfig)
+
+-set(K2PDFOPT_LIB "-lm")
++set(K2PDFOPT_LIB "-lm -ljasper")
+
+ # cmake -DCMAKE_BUILD_TYPE=Debug <path>
+
+diff -aur src.orig/k2pdfopt_v2.51/willuslib/bmp.c src/k2pdfopt_v2.51/willuslib/bmp.c
+--- src.orig/k2pdfopt_v2.51/willuslib/bmp.c 2019-01-01 00:21:16.000000000 +0100
++++ src/k2pdfopt_v2.51/willuslib/bmp.c 2019-03-24 21:45:48.713500408 +0100
+@@ -37,7 +37,7 @@
+ #include <jpeglib.h>
+ #endif
+ #ifdef HAVE_JASPER_LIB
+-#include <jasper.h>
++#include <jasper/jasper.h>
+ #endif
+
+ #define BOUND(x,xmin,xmax) if ((x)<(xmin)) (x)=(xmin); else { if ((x)>(xmax)) (x)=(xmax); }