summarylogtreecommitdiffstats
path: root/julia-makefile.patch
diff options
context:
space:
mode:
authorNarrat2018-11-22 02:19:30 +0100
committerNarrat2018-11-22 02:20:53 +0100
commit2e6c25adcc4d6e883367f908803dc421b9df64a9 (patch)
tree271750fe091d91a9df29de8f5ae7e176649c2e9c /julia-makefile.patch
parent81aa38a7dd616feaedbe69cbce587c1aba183987 (diff)
downloadaur-2e6c25adcc4d6e883367f908803dc421b9df64a9.tar.gz
Julia: Overhaul regarding 1.0 release
Incorporate changes from the repo PKGBUILD, which changes deps. System llvm cannot be used currently, as they use a patched version. Until those patches are upstreamed nothing can be done.
Diffstat (limited to 'julia-makefile.patch')
-rw-r--r--julia-makefile.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/julia-makefile.patch b/julia-makefile.patch
new file mode 100644
index 000000000000..0618b96803e3
--- /dev/null
+++ b/julia-makefile.patch
@@ -0,0 +1,14 @@
+--- Makefile.orig 2017-10-28 17:06:53.003582943 +0000
++++ Makefile 2017-10-28 17:07:27.690408154 +0000
+@@ -316,8 +316,9 @@
+ $(build_depsbindir)/stringreplace $$(strings -t x - $1 | grep '$2' | awk '{print $$1;}') '$3' 255 "$(call cygpath_w,$1)"
+ endef
+
+-install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
+- @$(MAKE) $(QUIET_MAKE) all
++docsindex: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
++
++install:
+ @for subdir in $(bindir) $(datarootdir)/julia/stdlib/$(VERSDIR) $(docdir) $(man1dir) $(includedir)/julia $(libdir) $(private_libdir) $(sysconfdir); do \
+ mkdir -p $(DESTDIR)$$subdir; \
+ done