summarylogtreecommitdiffstats
path: root/jupyterlab-git.install
diff options
context:
space:
mode:
authorFabian2018-02-19 16:22:59 +0100
committerFabian2018-02-19 16:26:33 +0100
commit3be371822cd8a76526786644669ffd370fa6f317 (patch)
treeb7d70694bb77f4db707d5fe278a41029fd8e980c /jupyterlab-git.install
parentb92777e789b38e8f44221d4869c1b31a7cc0a812 (diff)
downloadaur-3be371822cd8a76526786644669ffd370fa6f317.tar.gz
Update PKGBUILD for current git master
Diffstat (limited to 'jupyterlab-git.install')
-rw-r--r--jupyterlab-git.install21
1 files changed, 21 insertions, 0 deletions
diff --git a/jupyterlab-git.install b/jupyterlab-git.install
new file mode 100644
index 000000000000..353b851a62c3
--- /dev/null
+++ b/jupyterlab-git.install
@@ -0,0 +1,21 @@
+with_env() {
+ env \
+ JUPYTER_DATA_DIR=/usr/share/jupyter \
+ JUPYTER_CONFIG_DIR=/etc/jupyter \
+ "$@" --user
+}
+
+post_install() {
+ with_env jupyter serverextension enable --py jupyterlab
+}
+
+pre_remove() {
+ with_env jupyter serverextension disable --py jupyterlab
+}
+
+pre_upgrade() {
+ pre_remove
+}
+post_upgrade() {
+ post_install
+}