summarylogtreecommitdiffstats
path: root/keys-guard.patch
diff options
context:
space:
mode:
authorAlexander 'z33ky' Hirsch2017-08-01 22:50:45 +0200
committerAlexander 'z33ky' Hirsch2017-08-01 22:50:45 +0200
commita46a4c91140d196daa0653ff37eb05a34fec7efb (patch)
tree2e6e6972cd54f66767599105b17a7f19c48cd03d /keys-guard.patch
parent8d995ffb1798aafb204528820a36becb449d84de (diff)
downloadaur-a46a4c91140d196daa0653ff37eb05a34fec7efb.tar.gz
Update PKGBUILD with new data checksums
Also try to work around some build failures. If the patches don't apply, hope that the issues have been fixed.
Diffstat (limited to 'keys-guard.patch')
-rw-r--r--keys-guard.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/keys-guard.patch b/keys-guard.patch
new file mode 100644
index 000000000000..22498b38cb1c
--- /dev/null
+++ b/keys-guard.patch
@@ -0,0 +1,18 @@
+--- a/client/keys.h
++++ b/client/keys.h
+@@ -21,6 +21,9 @@
+ //
+ // these are the key numbers that should be passed to Key_Event
+ //
++#ifndef _KEYS_H_
++#define _KEYS_H_
++
+ typedef enum {
+ K_TAB = 9,
+ K_ENTER = 13,
+@@ -113,3 +116,5 @@
+ void Key_SetBinding (int keynum, char *binding);
+ void Key_ClearStates (void);
+ int Key_GetKey (void);
++
++#endif